Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 8
Registered: ‎01-16-2011
My Device: Blackberry 9700
My Carrier: Etisalat
Accepted Solution

Blackberry JRE 4.6.1 needed

Hello,

Its driving me crazy, ive searched everywhere and i cant find JRE 4.6.1. Ive downloaded the latest Eclipse + plugin 1.1.3 and it has only JRE 6.0. I want to develop for blackberry 8900 that has 4.6.1. Please help me guys.

 

PS: Ive searched for 2 days before posting this Smiley Happy

 

Many thanks

Yassine 

Developer
Posts: 82
Registered: ‎12-16-2010
My Device: BlackBerry Storm 9950

Re: Blackberry JRE 4.6.1 needed

http://us.blackberry.com/developers/javaappdev/javaupdate.jsp

 

I just had to do this for 5.0.

 

  1. From the Help menu, select Install New Software to open the Install window.
  2. Click the Add button:
    1. In the Add Site dialog, type the URL http://www.blackberry.com/go/eclipseUpdate/3.6/java into the location text box and specify BlackBerry Java Plug-in Update Site in the name text box.
    2. Click the OK button, BlackBerry Update Site appears in the Available Software list.
  3. Select the BlackBerry Java Plug-in item and at least one BlackBerry Component Pack item you want to work on.
  4. Click the Next button.
  5. Click the Next button after reviewing the items to be installed.
  6. Check the I accept the terms of the license agreement radio button after reviewing licenses.
  7. Click the Finish button to begin installation.

4.6 will be in the update package along with a few others

Highlighted
New Contributor
Posts: 8
Registered: ‎01-16-2011
My Device: Blackberry 9700
My Carrier: Etisalat

Re: Blackberry JRE 4.6.1 needed

Seriously respect. Thanks for the quick reply. Downloading now, will let you know with the results.

 

Thanks one more time.

 

Yassine

New Contributor
Posts: 8
Registered: ‎01-16-2011
My Device: Blackberry 9700
My Carrier: Etisalat

Re: Blackberry JRE 4.6.1 needed

One last thing. Now what why 6.0 is called JRE and 4.6.1 is called JDE? I thought they are 2 different thing.

Developer
Posts: 82
Registered: ‎12-16-2010
My Device: BlackBerry Storm 9950

Re: Blackberry JRE 4.6.1 needed

You're welcome, Yassine.