Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
jobincantony
Posts: 26
Registered: ‎08-04-2008
My Device: Not Specified

Blackberry OS 4.3 needed.(Bluetooth bugs in 4.2.x)

Hi,

 

I am developing an application for blackberry phones and i need to discover and pair some bluetooth devices through my application. I am using javax.bluetooth.* classes for discovering the BT devices. In 4.2.x OS, device discovery gives null values for ClassOfDevice value of remote device. Without this property we could not filter our devices from other Bluetooth enabled devices in range.

 

I have tested the application with OS v4.5.0.55 (BB model 8800) and it is working good.

 

Now i need to ensure that the application is working fine with OS v4.3.x

 

Blackberry phone models available with us are 8800, 8100, 8700, 7100, 7290, 7130, 8707, and 8703 .

 

Could anyone plz give the download location for BB os 4.3.x for any of these models.

Thanks in advance

Jobin

Developer
peter_strange
Posts: 19,610
Registered: ‎07-14-2008
My Device: Not Specified

Re: Blackberry OS 4.3 needed.(Bluetooth bugs in 4.2.x)

[ Edited ]

You might find the following link useful:

 

http://www.blackberryforums.com/rim-software/110673-useful-latest-os-all-models.html

 

Note that for some models there does not seem to have been a 4.3 release, either they haven't got there (for example the 7290) or they skipped it and went straight to 4.5 (for example 8700).

Message Edited by peter_strange on 08-29-2008 09:14 AM
BlackBerry Development Advisor (Retired)
mweitzel
Posts: 28
Registered: ‎07-14-2008
My Device: Not Specified

Re: Blackberry OS 4.3 needed.(Bluetooth bugs in 4.2.x)

Hi Jobin,

 

The only models that were released with v4.3 of the handheld software were the BlackBerry 8110, the BlackBerry 8120 and the BlackBerry 8130.

 

If you go to our BlackBerry Developers web site you could download a v4.3 simulator for the 8110 or 8120 but note that you will need a Cassira Bluetooth testing board in order to test the actual Bluetooth functionality (for more details about the testing board please the Java Developer Guide that comes with the JDE.

 

Regards,

Mike. 

Developer
rafo
Posts: 507
Registered: ‎07-15-2008
My Device: Not Specified

Re: Blackberry OS 4.3 needed.(Bluetooth bugs in 4.2.x)

Check this thread

 

I updated my BB 8800 T-Mobile to 4.5.0.85

 

But T-Mobile does not officially offer this version.

 

I just downloaded OS for Orange, installed it, deleted Vendor.XML file and installed this OS.

 

In case you will wish to downgrade your OS afterwards check this page

 

there is step-by-step instructions how to downgrade.

----------------
if your issue solved set "Solution" mark at the relevant post