Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
noybrw
Posts: 9
Registered: ‎05-27-2010
My Device: 9100
My Carrier: BIS

Blackberry Plug-In for eclipse and Blackberry JDE installation

Hello,

 

I just downloaded the new Blackberry Plug-in for eclipse 1.3.0 along with Eclipse Helios. My question is: do I need to also download the Blackberry JDE? And if so, how do I know which version is compatible with the Blackberry Plug-in for eclipse 1.3.0?

 

Thank You

 

Ramy Gerges

Please use plain text.
Developer
arkadyz
Posts: 2,268
Registered: ‎07-08-2009
My Device: various
My Carrier: various

Re: Blackberry Plug-In for eclipse and Blackberry JDE installation

No, Helios with Plug-in is completely self-contained and does not need the JDEs to work. There is one caveat, though - if you want to develop for BlackBerry pre-4.6, you'll need the appropriate JDE, as the Plug-in does not support older OS versions.

I wouldn't bother doing anything supporting older OS versions, but you can have a much more informed decision after looking here:

BlackBerry - Choosing a target OS

----------------------------------------------------------
please click 'Accept Solution' on posts that provide the solution to the question you've posted. Don't say "Thanks", press 'Like' button instead!
Please use plain text.
New Contributor
noybrw
Posts: 9
Registered: ‎05-27-2010
My Device: 9100
My Carrier: BIS

Re: Blackberry Plug-In for eclipse and Blackberry JDE installation

Then why is it that when on the Blackberry Java Plug-in for eclipse program when I click on Blackberry => Run As => Blackberry Simulator is not highleted as an option I can click on. Like I don't have a blackberry simulator installed on it? 

 

 

Please use plain text.
New Contributor
TessyJose
Posts: 8
Registered: ‎11-17-2011
My Device: developer
My Carrier: developer

Re: Blackberry Plug-In for eclipse and Blackberry JDE installation

Is blackberry jde 1.3.0 compatible for development for OS 5 ?

Please use plain text.