Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
narasinga
Posts: 29
Registered: ‎03-24-2010
My Device: black berry 8820
Accepted Solution

Blackberry Preprocessor Help

Hi Friends,

 

  I am confusion with Preprocessor  which was given by RIM in follow link,

 

http://supportforums.blackberry.com/t5/Java-Development/Use-the-preprocessor/ta-p/445231

 

as they said i have done preprocessor concept for Different OS as follows, 

Preprocessor Help

I have installed Eclipse with BlackBerry Java Plug-in  Version:  1.3.0.201102031007-19 (which is having by defalult os if 6.0.0) so i don't have lower OS.

 

if i want to write a code for both OS 5 and OS 6 how do i write. 

 

For Preprocessors, i have added manually BlackBerryOS5.0.0 to the Bulid path. in my code it is defines as ,

 

//#ifdef BlackBerrySDK6.0.0
  import net.rim.device.api.gps.LocationInfo;
//#endif

 

When i installed in OS 6 Devices it runs successfully but 

when i installed in OS5 Devices it shows, net.rim.device.api.gps.location not found.

 

Please help me here.

 

Regards,

K.Narasinga Rao.

Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: Blackberry Preprocessor Help

You need to install the 5.0 API in order to use it. Just adding the preprocessor will not allow you to compile with a lower version.
---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Contributor
narasinga
Posts: 29
Registered: ‎03-24-2010
My Device: black berry 8820

Re: Blackberry Preprocessor Help

Hi,

 

  I have already installed Blackberry OS 6.0 then how can i install downgrade version of the blackberry. If possible can you please provide me a link to it to download OS5.0 and install into Same Eclipse Folder path. 

 

K.Narasinga Rao.

Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: Blackberry Preprocessor Help

I went to the developer site, this is the link for the plugin: http://us.blackberry.com/developers/javaappdev/javaplugin.jsp

 

Look at "Eclipse updates" to be able to download the 5.0 SDK. Then you can change which SDK the project uses, it will automatically change the preprocessor to be 5.0.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Contributor
narasinga
Posts: 29
Registered: ‎03-24-2010
My Device: black berry 8820

Re: Blackberry Preprocessor Help

thank you,

 

  I will check and download the API 5.0 and respond with the result..

 

Contributor
narasinga
Posts: 29
Registered: ‎03-24-2010
My Device: black berry 8820

Re: Blackberry Preprocessor Help

hi 

 

thanks for this help. I got the required SDK.