Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
server3489
Posts: 86
Registered: ‎12-09-2008
My Device: Not Specified

Bold9700 Simulator hanging

[ Edited ]

Hello,

 

when debugging the Bold 9700 simulator with Eclipse, the simulator is hanging. I can go the simulator Menu and make changes, but the simulator itself, meaning Bold9700 firmware does not respond. If I minimize the whole simulator to the Windows taskbar and then getting it back to foreground, it responds. But then if I want to click to the next icon or doing anything else, it is hanging again. So for going to the "Download"-Folder I have to minimize the simulator several times.

Well, sometimes the simulator does not respond at all. But it is the same when my application is installed or when it is not installed!

 

The same happens when using the Bold9700 simulator standalone without eclipse.

 

I am using Vista 64-bit and Eclipse 3.4.1 and Blackberry Component Pack 4.5, 4.6.1, 4.7.0, 5.0.0 and the Blackberry Eclipse Plugin 1.0.0.67.

 

I uninstalled and installed Component Pack 5.0.0 several times yet.

 

Does anybody know how to fix this?

 

Thanks in advance.

Please use plain text.
Developer
JCarty
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Bold9700 Simulator hanging

Just a small note: Windows 64-bit (Vista and 7) are not officially supported by RIM.

 

I recommend you upgrade to the latest Eclipse plugin which was recently released (it is now version 1.1.2). This should solve some (but not all) issues since you are on 64-bit.

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Please use plain text.
New Contributor
kongxx
Posts: 3
Registered: ‎04-19-2010
My Device: 9700

Re: Bold9700 Simulator hanging

I also have the same problem. My os is windows2003(32bit), the simulator are 4.6.1, 4.7.0, 4.7.1 and 5.0.0

 

Please use plain text.
Developer
server3489
Posts: 86
Registered: ‎12-09-2008
My Device: Not Specified

Re: Bold9700 Simulator hanging

Well, I finally installed Eclipse 3.5.2 and the latest Blackberry Eclipse plugin 1.1.2, but all the issues mentioned above still exists.

Seems to be the 64-bit issue. I hope RIM will support 64-bit Windows Vista soon.

Please use plain text.