Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
LMcRae
Posts: 163
Registered: ‎04-16-2009
My Device: Not Specified

Broken OpenGL on Storm 2 OS 5.0.0.1015

  Does anyone know of the current status of the broken OpenGL support?  AFAIK all the 3D game, including mine, are broken.  Who do I forward all the hate mail to? 

 

  It's no wonder Super Monkey hasn't shown up if this is the way developers are treated.  First no OpenGL support for the Torch and now the main device that supports OpenGL is broken.  I'm considering dropping BlackBerry dev altogether and just concentrate on Android.  At the very least I'm developing for Android first with a very reluctant port to BlackBerry.

 

 It's very sad RIM, looks like I bet on the wrong horse.

 

Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: Broken OpenGL on Storm 2 OS 5.0.0.1015

What exactly is the problem you are having?

 

I have been able to port the first 8 tutorials from NeHe to BlackBerry (had some other tasks to complete so haven't got'n to others) so I know it works. Performance is the one issue I have.

 

The support issue has been admitted to be the chips used (Qualcomm has built in OpenGL support but does it on their CDMA chips, Torch is GSM thus it doesn't have it).

 

It is a pain in the butt but it's better to see it a work-around is possible before giving up hope entirely (or at least making it a late port).

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Developer
LMcRae
Posts: 163
Registered: ‎04-16-2009
My Device: Not Specified

Re: Broken OpenGL on Storm 2 OS 5.0.0.1015

 


rcmaniac25 wrote:

What exactly is the problem you are having?

 

I have been able to port the first 8 tutorials from NeHe to BlackBerry (had some other tasks to complete so haven't got'n to others) so I know it works. Performance is the one issue I have.

 

The support issue has been admitted to be the chips used (Qualcomm has built in OpenGL support but does it on their CDMA chips, Torch is GSM thus it doesn't have it).

 

It is a pain in the butt but it's better to see it a work-around is possible before giving up hope entirely (or at least making it a late port).


 

The issue is that the phone reboots.  My game is Tank Recon 3D but it also happens on Need For Speed Shift.  You're not likely seeing any problem because the demos are tiny.

 

Performance isn't actually that bad considering there is no OpenGL 1.1 support.  You need to make sure your rendering is done on it's own thread as swapping buffers will block.  Andriod is the same.

 

 

 

Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: Broken OpenGL on Storm 2 OS 5.0.0.1015

It reboots? While playing?

 

That's a new one for me. I need to make a bigger demo since I haven't encountered that.

 

Does the event log have anything on that? Any exception or random artifact that might have caused that issue?

 

As for performance, because they are just small demos I don't really mind the lower performance though I do run it on a separate thread. What I find weird is the higher up the demo (more complex) the faster it runs.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
New Contributor
juergen_thomann
Posts: 6
Registered: ‎02-01-2011
My Device: Storm 2 9520

Re: Broken OpenGL on Storm 2 OS 5.0.0.1015

 


rcmaniac25 wrote:

It reboots? While playing?

 

That's a new one for me. I need to make a bigger demo since I haven't encountered that.

 

Does the event log have anything on that? Any exception or random artifact that might have caused that issue?

 

As for performance, because they are just small demos I don't really mind the lower performance though I do run it on a separate thread. What I find weird is the higher up the demo (more complex) the faster it runs.


 

I have the same problem. See

http://supportforums.blackberry.com/t5/BlackBerry-Storm-BlackBerry-9500/storm2-9520-crashes-when-usi...