Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Highlighted
Regular Contributor
Posts: 64
Registered: ‎02-03-2010
My Device: Bold
My Carrier: Orange

BrowserField2 Error navigating to page

Hi, i have been breaking my head the past day with this problem  : 

 

I am trying to connect to the following url  :

 

 https://graph.facebook.com/oauth/authorize_success?scope=offline_access%2Cpublish_stream&redirect_ur...

 

The blackberry browser opens it just fine, but the browerField im using displays an error saying 

 

"error navigating to "  - url - and then "Could not select proper Transport Descriptor."

 

I conclude that my problem is one of opening a connection to the url, but i don't understand why. I have tried playing around ConnectionFactory, and its setPreferredTransportTypes, to force using some connection or the other, such as WAP instead of BIS, etc., but no success.

 

Other urls i open with the browser field work just fine, also https ones, so i'm not able to understand what exactly is different with this one. FYI, this url is supposed to perform a redirection to another url, but never gets around to it. 

 

I would be eternally grateful for anyone who can help me Smiley Happy

 

Thanks

Dan.

 

 

 

New Contributor
Posts: 5
Registered: ‎09-15-2010
My Device: Not Specified

Re: BrowserField2 Error navigating to page

I'm having the same issue.

Do you know if this a BrowserField issue? Is there a workaround?

Thanks, Pablo

Contributor
Posts: 10
Registered: ‎02-08-2010
My Device: Bold 8900
My Carrier: T-Mobile

Re: BrowserField2 Error navigating to page

Hi,

 

I am facing the same issue

 

Error navigating to:

 

URL -

 

Erro message: Stream closed

 

This issue is occuring when trying to Login into facebook thru BlackBerry api. Smiley Sad

 

Can some one help me in this. Same code is working on Strom but not on Bold OS ver 5.0.03

 

 

Contributor
Posts: 10
Registered: ‎02-08-2010
My Device: Bold 8900
My Carrier: T-Mobile

Re: BrowserField2 Error navigating to page

Hello,

 

Somebody can please help me in solving this weired issue "Unable to login into Facebook (used in my application) through BlackBerry Bold device version 5.0.0.330

 

Thanks in advance !!

-Rucha

Contributor
Posts: 15
Registered: ‎03-03-2009
My Device: Storm
My Carrier: BB Developer

Re: BrowserField2 Error navigating to page

same facebook login problem with  tourch 9800 6.0.0.284

New Contributor
Posts: 2
Registered: ‎05-11-2011
My Device: 9700 and 9780
My Carrier: Vodafone

Re: BrowserField2 Error navigating to page

I'm having the same problem too on my 9700 (OS 5), although it works fine on my 9780 (OS 6).

 

I see the login page, but once I've entered my credentials and hit 'Login', it shows the error page in the browser.

 

I notice that your URL is pretty long (622 characters) - mine is pretty long too (580 characters), perhaps that is the problem?

 

Anyone got any other ideas?

New Member
Posts: 1
Registered: ‎12-06-2011
My Device: 9700
My Carrier: att

Re: BrowserField2 Error navigating to page

Has anyone found a solution to this problem?

New Contributor
Posts: 8
Registered: ‎08-18-2011
My Device: 9000
My Carrier: Vodafone

Re: BrowserField2 Error navigating to page

I am also having this issue while connecting to Facebook using browser field.

if i use the wi-fi and TCP to connect then it works but for BIS connection it is showing Could not select proper descriptior error.