Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Member
pollifax
Posts: 1
Registered: ‎03-17-2011
My Device: OS 4.5 and up
My Carrier: AT&T and Verizon

Can't install 4.x component packs in Eclipse plug-in 1.3.0

When I use the update site http://www.blackberry.com/go/eclipseUpdate/3.6/java

or  http://www.blackberry.com/go/eclipseUpdate/3.5/java and choose any 4.x component pack, I eventually get the following error message:

 

"An error occurred while collecting items to be installed
session context was:smileysad:profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA....
Server returned HTTP response code: 500 for URL: https://www.blackberry.com/Downloads/downloadFile;jsessionid=A73BDF99EE471CC1A1A5CDA72ADA8ABB.node1?..."

 

I was finally able to find one of the zipped component packs online (they seem to be hidden) and downloaded it for manual installation using the archive option.  I got this error message:

 

"Cannot complete the install because one or more required items could not be found.
Software currently installed: BlackBerry Component Pack 4.6.1 4.6.1.27 (net.rim.eide.feature.componentpack4.6.1.feature.group 4.6.1.27)
Missing requirement: BlackBerry JDE Component Package 4.6.1 4.6.1.27 (net.rim.eide.componentpack4.6.1 4.6.1.27) requires 'bundle net.rim.eide 0.0.0' but it could not be found
Cannot satisfy dependency:
From: BlackBerry Component Pack 4.6.1 4.6.1.27 (net.rim.eide.feature.componentpack4.6.1.feature.group 4.6.1.27)
To: net.rim.eide.componentpack4.6.1 [4.6.1.27]"

 

Can anyone help?

Thanks!

Please use plain text.
New Developer
New Developer
rzr
Posts: 151
Registered: ‎01-05-2010
My Device: dev alpha c (bb10)
My Carrier: www.rzr.online.fr

Re: Can't install 4.x component packs in Eclipse plug-in 1.3.0

[ Edited ]

yes i have the same trouble,

 

http://supportforums.blackberry.com/t5/Java-Development/Eclipse-update-site-keeps-nagging-for-passwo...

 

 

!ENTRY org.eclipse.equinox.p2.engine 4 4 2011-03-31 18:11:44.869
!MESSAGE An error occurred while collecting items to be installed
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2011-03-31 18:11:44.869
!MESSAGE session context was:smileysad:profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
!SUBENTRY 1 org.eclipse.equinox.p2.repository 4 1007 2011-03-31 18:11:44.869
!MESSAGE Unable to read repository at: https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA... Too many failed login attempts.

 

Are there some alternate mirror we can use to work on previous platform ?

 

Please use plain text.