Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
jaakl
Posts: 4
Registered: ‎05-19-2009
My Device: Not Specified

Cannot install eclipse plugin

[ Edited ]

I've spent many hours to install Eclipse plugins for older OS versions (4.5, 4.6, 4.7).

 

I started with "full installer" bundle (1.1.2 plugin version and eclipse 4.5), which includes only 5.0 package. Apparently if  I connect it to 4.6 device, then I get "verification error" results, so most probably I need also older version.

 

Tried many times (from different local networks) to install from Eclipse Update site http://www.blackberry.com/go/eclipseUpdate/3.5/java, this ends always the well-known connection exception (Transfer Exception Read timed out)

 

Then tried to run Eclipse with JDK 1.5 as suggested in this post, no help.

 

Then found post from forum which suggested to download .zip files with plugin component archives. The referred page from there http://na.blackberry.com/eng/developers/javaappdev/javaplugin.jsp seems to have no these .zip files anymore. I got one (eJDE-4_6_0_19_Component.zip) from a colleague's local archive, but this ended with following not so helpful message. Plugins directory  seems to have 4.6 component's dir, but plugin itself is not active and cannot be used. Probably the component.zip was for older plugin version.

 

Question: Can we have downloadable .zip files for the latest plugin packages again?

 

 

Cannot complete the install because one or more required items could not be found.
  Software currently installed: BlackBerry Component Pack 4.6.0 4.6.0.19 (net.rim.eide.feature.componentpack4.6.0.feature.group 4.6.0.19)
  Missing requirement: BlackBerry JDE Component Package 4.6.0 4.6.0.19 (net.rim.eide.componentpack4.6.0 4.6.0.19) requires 'bundle net.rim.eide 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: BlackBerry Component Pack 4.6.0 4.6.0.19 (net.rim.eide.feature.componentpack4.6.0.feature.group 4.6.0.19)
    To: net.rim.eide.componentpack4.6.0 [4.6.0.19]

Cannot complete the install because one or more required items could not be found.  Software currently installed: BlackBerry Component Pack 4.6.0 4.6.0.19 (net.rim.eide.feature.componentpack4.6.0.feature.group 4.6.0.19)  Missing requirement: BlackBerry JDE Component Package 4.6.0 4.6.0.19 (net.rim.eide.componentpack4.6.0 4.6.0.19) requires 'bundle net.rim.eide 0.0.0' but it could not be found  Cannot satisfy dependency:    From: BlackBerry Component Pack 4.6.0 4.6.0.19 (net.rim.eide.feature.componentpack4.6.0.feature.group 4.6.0.19)    To: net.rim.eide.componentpack4.6.0 [4.6.0.19]

 

Update: exact message from "normal" installation procedure using Eclipse update:

 

An error occurred while collecting items to be installed

  session context was:smileysad:profile=epp.package.java, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Collect, operand=, action=).

  Unable to read repository at http://downloads.blackberry.com/upr/developers/javadev/net.rim.ejde.componentpack4.5.0_4.5.0.28.jar.

  Read timed out

 

Please use plain text.
BlackBerry Development Advisor
kwallis
Posts: 136
Registered: ‎01-19-2010
My Device: BlackBerry Z10
My Carrier: AT&T

Re: Cannot install eclipse plugin

Hi jaakl.  We are looking into the issue you are encountering with connecting to the update site.  We had made some recent changes that helped reduce the occurence of the expections, but apparently not solved it altogether. :smileywink:

 

I'll report back as soon as I get some more information.

Ken Wallis - Senior Product Manager, WebWorks and Android Runtime
@ken_wallis
Please use plain text.
Administrator
MSohm
Posts: 14,446
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Cannot install eclipse plugin

[ Edited ]

Can you enable networking logging in Eclipse and try the install again?  Once complete please send the logs to devsupport@rim.com referring to this post.

 

 

To enable network logging first add following VM settings after “-Xmx256m” line in “eclipse.ini” file -Dorg.apache.commons.logging.Log=org.apache.commons.logging.impl.SimpleLog -Dorg.apache.commons.logging.simplelog.showdatetime=true -Dorg.apache.commons.logging.simplelog.log.httpclient.wire.header=debug -Dorg.apache.commons.logging.simplelog.log.org.apache.commons.httpclient=debug

 

Now, start Eclipse from a command prompt using “eclipsec 2>stderr.txt”.

 

To do so:

 

• Open a command prompt window

• Navigate to your Eclipse install folder

• Run “eclipsec 2>stderr.txt”.  The communication log will be recorded in “stderr.txt” file.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Contributor
Symbi
Posts: 27
Registered: ‎08-05-2010
My Device: 9700

Re: Cannot install eclipse plugin

Hello, to everybody!

I want to ask You, Has somebody solved this problem with updating the plugin?

Do We have any possibility to develop applications for OS 6 with eclipse at this moment?

Thank You.

Please use plain text.
Regular Contributor
santacrab
Posts: 70
Registered: ‎10-06-2010
My Device: BB 9780

Re: Cannot install eclipse plugin

UP!!

 

Any news on the Update Site for Eclipse???

Please use plain text.
Administrator
MSohm
Posts: 14,446
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Cannot install eclipse plugin

If you are receiving the same error that has been reported above, please perform the logging steps found in my previous post above.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Contributor
prem82
Posts: 6
Registered: ‎11-24-2010
My Device: Blackberry Curve 8520
My Carrier: Airtel India

Re: Cannot install eclipse plugin

Hi Guys, Even I faced this issue for quite some time and found a workaround. Hope that will help you too. 1. Download the BlackBerry Java Plug-in for Eclipse v1.1 (full installer). Its better and faster than the v1.0 http://us.blackberry.com/developers/javaappdev/devtools.jsp This Plugin comes with Eclipse 3.5 for Java and has the component pack 5.0 installed in it. I needed to use the older component pack 4.5. I tried Eclipse Update site http://www.blackberry.com/go/eclipseUpdate and got the same errors. Then I downloaded the jar files for all the component packs installed it in Eclipse. Works perfectly. Here are the links. http://downloads.blackberry.com/upr/developers/javadev/net.rim.ejde.componentpack4.5.0_4.5.0.28.jar http://downloads.blackberry.com/upr/developers/javadev/net.rim.ejde.componentpack4.6.0_4.6.0.23.jar http://downloads.blackberry.com/upr/developers/javadev/net.rim.ejde.componentpack4.6.1_4.6.1.49.jar http://downloads.blackberry.com/upr/developers/javadev/net.rim.ejde.componentpack4.7.0_4.7.0.57.jar http://downloads.blackberry.com/upr/developers/javadev/net.rim.ejde.componentpack6.0.0_6.0.0.29.jar 1. Please download the jars into local machine. 2. Go to the eclipse plugin folder. Mine is D:\Prem\InstalledApps\EclipseJDE1.1\plugins 3. Extract the contents of the jar file to this folder with the same name of the jar file. Jar Name: net.rim.ejde.componentpack4.5.0_4.5.0.28.jar Folder Name: net.rim.ejde.componentpack4.5.0_4.5.0.28 The contents of the jars should be extracted in to this folder. D:\Prem\InstalledApps\EclipseJDE1.1\plugins\net.rim.ejde.componentpack4.5.0_4.5.0.28 4. Restart Eclipse. 5. Create a new blackberry project. You can see the new Blackberry JRE in the dropdown. Select the one you want to use. 6. You can select from one of the simulators available for that component pack from the debug/run dialog. Or, alternatively you can download the simulators from the blackberry site. Let me know if this helps or you need additional information. Thanks, Prem
Please use plain text.
New Developer
cavilah
Posts: 52
Registered: ‎10-28-2010
My Device: Not Specified

Re: Cannot install eclipse plugin

hi i have the same problem i need JDE 5.0 .zip because when i try with .jar eclipse doesn't detect  it

 

 

Please use plain text.
New Contributor
prem82
Posts: 6
Registered: ‎11-24-2010
My Device: Blackberry Curve 8520
My Carrier: Airtel India

Re: Cannot install eclipse plugin

Hi,

   JDE 5.0 comes pre-installed with BlackBerry Java Plug-in for Eclipse v1.1 (full installer). Please download the eclipse and the plugin together from balckberry site.

Please use plain text.
Contributor
NiKeighley
Posts: 31
Registered: ‎11-21-2010
My Device: Curve 8520
My Carrier: Virgin Media

Re: Cannot install eclipse plugin

where do I find that?

 

how do install it?

 

is that the the correct JDE for a curve 8520 (I guess "yes" as you've listed it as your platform)

 

 

[sorry for seming helplessness but I've spent the last 6 hours trying to get a working development environment!]

Please use plain text.