Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
JoVinz
Posts: 255
Registered: ‎05-03-2012
My Device: 9930
My Carrier: Vodafone
Accepted Solution

Class 'net.rim.device.api.ui.ScrollView' not found in JDE 5

In simulator 8330 and on device 8530, my app crashes got alert that  "net.rim.device.api.ui.ScrollView"  not found. I am not using any Scrollview class. Which class should be using this ScrollView??

Please use plain text.
Developer
simon_hain
Posts: 15,863
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: Class 'net.rim.device.api.ui.ScrollView' not found in JDE 5

scrollview is a class that is new in OS 6.
make sure that you compiled the application using JRE 5 and that you don't use any libraries that may be compiled against a higher JRE.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
pradeep_ch
Posts: 543
Registered: ‎12-23-2010
My Device: Bold
My Carrier: Airtel

Re: Class 'net.rim.device.api.ui.ScrollView' not found in JDE 5

Hi Jovinz,

 

I am sure that this is the problem with JDE version you have used while building the app and device OS version you are trying to run.

If you build with higher version and you are trying to run in lower version OS then you will get this.

 

Thanks.

Please use plain text.
Developer
JoVinz
Posts: 255
Registered: ‎05-03-2012
My Device: 9930
My Carrier: Vodafone

Re: Class 'net.rim.device.api.ui.ScrollView' not found in JDE 5

Ok.. thank you..shuld i check in class?
Please use plain text.
Developer
simon_hain
Posts: 15,863
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: Class 'net.rim.device.api.ui.ScrollView' not found in JDE 5

check the JRE level you use to compile.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
JoVinz
Posts: 255
Registered: ‎05-03-2012
My Device: 9930
My Carrier: Vodafone

Re: Class 'net.rim.device.api.ui.ScrollView' not found in JDE 5

Its 1.3
Please use plain text.
Developer
simon_hain
Posts: 15,863
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: Class 'net.rim.device.api.ui.ScrollView' not found in JDE 5

the JRE of the blackberry OS, on properties/build path/libraries, JRE System Library.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
JoVinz
Posts: 255
Registered: ‎05-03-2012
My Device: 9930
My Carrier: Vodafone

Re: Class 'net.rim.device.api.ui.ScrollView' not found in JDE 5

It is Blackberry JRE 7.0.0.
Please use plain text.
Developer
simon_hain
Posts: 15,863
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: Class 'net.rim.device.api.ui.ScrollView' not found in JDE 5

it has to be the same (or lower) compared to the OS level of the device.
that means if you develop for an OS 5 device you have to set it to 5.0.0 (or lower)
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
JoVinz
Posts: 255
Registered: ‎05-03-2012
My Device: 9930
My Carrier: Vodafone

Re: Class 'net.rim.device.api.ui.ScrollView' not found in JDE 5

What should i do then? pls give me advice..
Please use plain text.