Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
tunde011
Posts: 17
Registered: ‎04-09-2012
My Device: BB9900
My Carrier: 02

Class ‘net.rim.device.api.ui.ScrollView’ not found”

I am having this error, I understand it is because I am running it on a simulator that uses OS version 5 and the class got introduced in 6. 

 

I am gone through all my files and did not import this class. I then went to the java docs  and realised my application uses  things like Horizontal_Scroll, No  Vertical_Scroll etc. Is this what is causing the error? If so, what are the alternatives available to use instead of Horizontal_Scroll

Please use plain text.
Developer
simon_hain
Posts: 15,872
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: Class ‘net.rim.device.api.ui.ScrollView’ not found”

[ Edited ]

no, these flags are fine.


is your eclipse set to JRE 5 or lower when building?
i would suggest to clean the build, recompile and try again.

 

also make sure you are not using any libraries that may be compiled against 6.0 or higher. 

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Contributor
tunde011
Posts: 17
Registered: ‎04-09-2012
My Device: BB9900
My Carrier: 02

Re: Class ‘net.rim.device.api.ui.ScrollView’ not found”

Mine is set to jre7. So I'm guessing, I should download jre5 or lower and work with that...

 

Thanks Simon!

Please use plain text.
Developer
simon_hain
Posts: 15,872
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: Class ‘net.rim.device.api.ui.ScrollView’ not found”

the simulator (or device) needs to be on the same or higher level compared to the JRE, as the JRE is only downwards compatible.

you can use a JRE 7 simulator, or download JRE 5 to continue with the JRE 5 simulator.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.