Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Regular Visitor
Posts: 1
Registered: ‎05-14-2011
My Device: bold 9700
My Carrier: Claro HN
Accepted Solution

Class not found exception after adding a new image to the resource folder.

The app works perfectly fine on the simulator and on the device. After adding a new sets of images, it started to show on every run, on the simulator and on the device, a class not found exception.

 

When trying to delete some images to find the cause, I get different classes not found when running. Compiling and packaging the application generates no warning or error. They even get signed. Some of the classes not found exception I get:

 

java.lang.stringbuilder

net.rim.device.api.ui.uiapplication

 

I am guessing it has something to do with the total image size, since the size of each image range from 100KB to 300KB, and we are talking of only 25 or 30 images in total. Adding the image outside of the 'res' folder doesn't generate the error, but the image isn't added to the final files.

 

Also, this application is not big, but when compiling, and packaging the app, it generates and signes 125 cod files. Is that normal?

 

I am using Eclipse 3.6(Helios), and BB SDK 5.0.0.25 won Win 7

 

Any help will be appreciated. Thanks.

 

 

Developer
Posts: 19,624
Registered: ‎07-14-2008
My Device: Not Specified

Re: Class not found exception after adding a new image to the resource folder.

Have you seen this?

 

http://supportforums.blackberry.com/t5/Testing-and-Deployment/The-maximum-size-of-a-BlackBerry-smart...

 

I would recommend that you download these sorts of resources and put them on the SD Card. Otherwise you are taking up storage that users will want to keep available for emails and the like.