Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
shism2
Posts: 246
Registered: ‎12-13-2010
My Device: Not Specified

Re: Commmunication API keeps using GET

Yes, if I use httpconnection to connect via bis-b it works normally. I'm also not using a user agent with the word blackberry in it. So, the problem isn't that the communication api is using "get". There is something else going on.
Please use plain text.
Developer
shism2
Posts: 246
Registered: ‎12-13-2010
My Device: Not Specified

Re: Commmunication API keeps using GET

[ Edited ]

The problem occurs with any url that I use. I tried removing the headers I placed one by one and that didn't make a difference either.

 

The network diagnostic tool says that my phone has BIS-B post and get.

Please use plain text.
Developer
shism2
Posts: 246
Registered: ‎12-13-2010
My Device: Not Specified

Re: Commmunication API keeps using GET

The problem also happens on OS 6
Please use plain text.
BlackBerry Development Advisor
MSohm
Posts: 14,689
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook

Re: Communication API keeps using GET

Are you able to open the URL on your server using the BlackBerry Browser?  What data services are enabled on the device (as listed by the Network Diagnostic tool)?

 

Can you elaborate on the error you are getting?  Are you getting an Exception on the device side?  If so what is it and what are it's .toString details?  If it's an error response generated by the server, what difference are you seeing on the server side that's causing that error?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.