Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
skyriser
Posts: 4
Registered: ‎11-27-2008

Developing for 7210, need JDE 3.6 or 3.7?

Hello all,

 

A while ago I was developing for a Blackberry 7210, and had installed JDE 3.6 or 3.7.


On a new computer now, trying to setup the dev tools, I couldn't find where to download JDE 3.6 or 3.7, the lowest I could find is version 4.0.

 

I tried a simple hello world program, works fine in the 7200 simulator, but tried to send it (by USB using the Desktop Manager), and it's giving me an error:

Unspecified error encountered [J:0x0000000A]

From what I remember it means I'm using a JDE that's more recent than the OS of the 7210, right?

 

A few questions...

-Is there a setting in the JDE 4.0 that can let me develop for the 7210?

-Is it possible to still download JDE 3.6 or 3.7?

 

Thanks!

Chris

Please use plain text.
Developer
peter_strange
Posts: 19,521
Registered: ‎07-14-2008

Re: Developing for 7210, need JDE 3.6 or 3.7?

You can't fool OS 4.0, you need the right OS Level.

 

I have both 3.6 (32 Mb) and 3.7 (34 Mb), however I believe I would be breaking the terms of my agreement (the one I agreed to when I downloaded them) if I passed them on.  You could try sending an email to support at blackberry dot net and ask them if they will make it available to you.

 

Good luck!

Please use plain text.
Developer
Posts: 5,339
Registered: ‎09-20-2008
My Carrier: ***

Re: Developing for 7210, need JDE 3.6 or 3.7?

JDE version is not hard-linked to the device model.

 

It is linked to the Handheld OS version.

 

If you have Handheld OS version 4.0 on your old device - it is possible to deploy applications compiled in JDE 4.0. Lower JDE version also will be suitable.

 

To select a JDE version to use the point you have to decide is the Handheld OS version, rather than a particular device model.

Please use plain text.
Developer
peter_strange
Posts: 19,521
Registered: ‎07-14-2008

Re: Developing for 7210, need JDE 3.6 or 3.7?

Good point, and this page suggests that 4.0 software is available for these devices from certain carriers:

 

http://www.blackberryforums.com/rim-software/110673-useful-latest-os-all-models.html

Please use plain text.
New Developer
skyriser
Posts: 4
Registered: ‎11-27-2008

Re: Developing for 7210, need JDE 3.6 or 3.7?

Thanks peter_strange, i'll see if I can update my device to a JDE compatible version.

Thanks!

Please use plain text.