Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 1
Registered: ‎04-07-2009
My Device: Not Specified

Direct TCP connection issues on bold

There is a chance this might not belong on a blackberry development message board, but my guess is, it does belong here.

 

My connection the Blackberry Bold appears to have trouble with setting the APN from the blackberry settings menu. 

1) Trouble specifically means that the RadioStatusListener interface returns PDP_CAUSE_AUTHENTICATION_FAILED as cause in the pdpStateChange callback (with state being PDP_STATE_REJECTED).

2) If I incorporate the APN information in the connectionstring when opening a connection, this trouble does not appear.

3) This problem also does not appear on other devices than the Bold.

4) In addition,the problem seems to only surface on Vodafone,

5) TMobile and KPN (in Holland) do not appear to have this problem, but I could not test this latter assumption enough, as we switched to Vodafone recently.

 

Some more information. I've encountered this about two weeks ago when I thought development of our product was nearing completion, all I needed to do was test the Bold. We develop our application on JDE 4.2.1, so our users do not need to fill in which platform they run on when they want to download our client. Opening a connection on the Bold appeared to be haphazard. I constructed a debug log to see what was happening behind the scenes on the radio. It appears that, on the Bold, after an initially successful APN resolving / PDP context session (which leads to transmission of data to our UDP/TCP server) the PDP context times out (which I assume is natural behaviour), and moments later is rejected (I assume unnaturally), with the PDP state mentioned above, which is 'authentication failed'.All this happens only when inputting the APN via the Settings -> Advanced -> Tcp route. If we try to enter the very same APN information directly into the connectionstring (e.g. using: udp://server:port;listenport/live.vodafone.com;TunnelAuthUsername=vodafone;TunnelAuthPassword=vodafone), the connection will succeed.

 

This leads me to believe that the Blackberry Bold does not correctly pick up the APN information on subsequent connection calls. One remote possibility is that the problem is related to us using Bold's which were sim-locked to Roger, but unlocked using the mechanism provided by Rogers. 

 

Does anyone have any info, or any hints and / or suggestions about this?

BlackBerry Development Advisor
Posts: 15,301
Registered: ‎07-09-2008
My Device: BlackBerry Passport
My Carrier: Bell

Re: Direct TCP connection issues on bold

What is the full, 4 digit BlackBerry handheld software version are you testing on?  You can find this under Options, About on the BlackBerry Smartphone.

 

Double check that there is no white space in the APN information configured under Options, Advanced Options, TCP.  A blank space at the end of a field can cause the BlackBerry to fail to connect through the APN.

 

 

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Highlighted
New Developer
Posts: 7
Registered: ‎11-12-2009
My Device: Not Specified

Re: Direct TCP connection issues on bold

Hi All,

 

I have same problem, The application running any other device and BB bold 9000 but application not connected the web service only which used to BES. In application, which page want connect to web service the application display error page but which page not connect to web service application display screens normally.

 

Please, explain details how to use that;

 

"connectionstring (e.g. using: udp://server:port;listenport/live.vodafone.com;TunnelAuthUsername=vodafone;TunnelAuthPassword=vodafone)"

 

Is it for APN setting or that you used to code for connection internet in your application code?

 

Does anyone have any info, or any hints and / or suggestions about this?

 

Developer
Posts: 16,839
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Direct TCP connection issues on bold

what is the result of the network diagnostic?

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800451/800563/What_Is...

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter