Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
rgelb1
Posts: 108
Registered: ‎08-05-2008
My Device: Not Specified

Does JDE need to match the OS???

I've read a comment today that made me say, hmm...  Is it true that the JDE in which I am compiling my apps need sto match the OS on the BlackBerry?

 

If that is the case, is it possible to down-compile in JDE 4.5?  I got most users on 4.3 and others on 4.5.  

 

Or do I have to have multiple versions of the JDE installed on my box?  Will the code compiled in JDE 4.3 work with devices that have Blackberry OS 4.5 installed?

 

How is this typically done from a developer's standpoint?  What are the best practices?  And finally, does RIM keep a tally of usage of each version of the OS somewhere, so I know how to better to target the market?

 

Thanks.  

Please use plain text.
Developer
simon_hain
Posts: 16,042
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: Does JDE need to match the OS???

you can use software developed with 4.3 on all devices further up.
i usually develop using 4.2.1 until i want things only possible in later releases.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
rgelb1
Posts: 108
Registered: ‎08-05-2008
My Device: Not Specified

Re: Does JDE need to match the OS???

So, are you saying that I need to uninstall JDE 4.5 and install JDE 4.2 if I want to support devices with OSes 4.2 and higher?  Isn't there some multi-targeting support, like in other IDEs?

 

 

Please use plain text.
Developer
peter_strange
Posts: 19,601
Registered: ‎07-14-2008
My Device: Not Specified

Re: Does JDE need to match the OS???

No need to uninstall but you will need to install 4.2.  See:

 

What Is - Appropriate version of the BlackBerry JDE
Article Number: DB-00537

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800738/800901/What_Is...


There have been a number of threads on this forum discussing this and ways to support multiple levels, the best I think is this one:

http://supportforums.blackberry.com/rim/board/message?board.id=java_dev&message.id=1079

Please use plain text.
Developer
rafo
Posts: 507
Registered: ‎07-15-2008
My Device: Not Specified

Re: Does JDE need to match the OS???

JDE does not support multi-targeting.

 

You may install several JDE's on to your computer and use appropriate JDE when you need that.

 

----------------
if your issue solved set "Solution" mark at the relevant post
Please use plain text.