Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
niravz
Posts: 5
Registered: ‎08-11-2011
My Device: Blackberry Curve 3G
Accepted Solution

Eclipse Indigo Support

Hey,

 

I am just kicking off to learn development on BB Platform, and have been going through a lot of links all over the web of BB to learn what would be the requirements to do so.

 

The most basic question I had was: choose between Eclipse and Netbeans. I asked my peers which IDE would be better, and although, most of them said Eclipse, since I have had experience with the same, I am much happier to choose this.


However, for BB App Dev, I kept wondering which version to go for.

A lot of places on the web, I found that support for Eclipse Indigo (3.7.x) hasn't yet taken concrete shape.

There's at least one page on the BB Website which states that support continues for Eclipse Helios (3.6.x).

Most commonly, people over the web suggest going for Galileo (3.5.x).

 

I would like to have some input as to which should I opt for?

 

Thanks :smileyhappy:

Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: Eclipse Indigo Support

Welcome. Go Eclipse 3.6. The current BlackBerry plugin is 1.3 and only supports 3.6. Note: You need to download the BlackBerry "version" of Eclipse because it has the plugin preinstalled (for one reason or another the downloadable form of the plugin hasn't been released). But there are some examples of how to use an already-in-use version of Eclipse and the 1.3 plugin.
---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
New Contributor
niravz
Posts: 5
Registered: ‎08-11-2011
My Device: Blackberry Curve 3G

Re: Eclipse Indigo Support

As far as I have seen the resource links, I did find a page, which downloads Blackberry Plugin. I am not sure, what you mean by " for one reason or another the downloadable form of the plugin hasn't been released).
In fact, I did download a plugin (321 MB :smileysurprised: - first plugin of any application that I have seen to have such a large size!)
Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: Eclipse Indigo Support

That;s because it's the entire Eclipse IDE, with the plugin included. You can download the different OS APIs through the Eclipse Update site. You used to be able to do that with the plugin itself.
---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
New Contributor
niravz
Posts: 5
Registered: ‎08-11-2011
My Device: Blackberry Curve 3G

Re: Eclipse Indigo Support

Thank you. :smileyhappy:

That resolved my query. :smileywink:
New Contributor
niravz
Posts: 5
Registered: ‎08-11-2011
My Device: Blackberry Curve 3G

Re: Eclipse Indigo Support

However, I found that the version of Blackberry plugin that I downloaded had the version 1.1.2 and the Eclipse that got installed was not 3.6, but 3.5. Can you provide me the link to 1.3 Eclipse plugin.

Thanks.
Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: Eclipse Indigo Support

Not sure where you got that one, try this:

http://us.blackberry.com/developers/javaappdev/javaplugin.jsp

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
New Contributor
niravz
Posts: 5
Registered: ‎08-11-2011
My Device: Blackberry Curve 3G

Re: Eclipse Indigo Support

Thanks. That's pretty much what I require. I'll try to find back the link from where I downloaded the 1.1.2 version and report it for change. :smileyhappy: