Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 13
Registered: ‎02-26-2010
My Device: Blackberry 9700
My Carrier: Tmobile

Eclipse Plugin, resource editor does not open

I'm using the eclipse plugin, and I cant seem to open the resource editor to edit a .rrh or .rrc file.

I keep getting this error: No editor descriptor for id org.eclipse.ui.internal.emptyEditorTab

 

I followed the example tutorial here  and I created a blank .rrc and .rrh packages, named them the same name as the app name. Tried to open it in the editor, and I get the error above.?

 

Does anyone know how to edit the resource files within eclipse?

 

I'm using

Eclipse IDE
Version: Juno Service Release 1

BlackBerry Java Plug-in
Version:  2.0.0.201207181003

New Contributor
Posts: 5
Registered: ‎03-29-2012
My Device: 9700
My Carrier: umobile

Re: Eclipse Plugin, resource editor does not open

Same here, i'm on windows 7 sp1, java 1.6.0_33

 

Eclipse SDK
Version: 4.2.1
Build id: M20120914-1800

 

BlackBerry Java SDK
Version:  5.0.0.36

BlackBerry Java Plug-in
Version:  1.5.2.201204302029

 

I do hope someone will be able to provide a solution

New Contributor
Posts: 2
Registered: ‎01-15-2013
My Device: 9300
My Carrier: Indosat

Re: Eclipse Plugin, resource editor does not open

I also have this issue. I think it's a kind of bug in Eclipse, because sometimes surprisingly I can open the resource editor, but next time I can't open it and get the same error. I'd like to try fresh and latest installatation of Juno and also BB Java SDK, but of course it is highly cost for time and bandtwith for me. But if it doesn't matter you, please try and report the result here. I will really appreciate it. :smileyhappy:

Developer
Posts: 19,628
Registered: ‎07-14-2008
My Device: Not Specified

Re: Eclipse Plugin, resource editor does not open

I remember I had some issues and I think I hacked it.  From memory, I was getting so that sometimes it would open, and then it wouldn't, with a Java exception.  I was creating a resource file for another langauge.  So I created a new one using the 'Wizard', and tested this - this consistently worked.  So I then shut down Eclipse and looked for the resource files.  Then updated these manually to match what I wanted and it all seemed to work.  Fingers crossed.  I know this doesn't help much, but I guess I'm telling you someone else has been there and got through it!

New Contributor
Posts: 2
Registered: ‎09-06-2012
My Device: Torch 9800
My Carrier: Bell

Re: Eclipse Plugin, resource editor does not open

[ Edited ]

I am also having this issue, using Eclipse Juno on WIndows 7. I went through all the steps above, and also used the "Wizard" mentioned by peter_strange. However I am still getting a blank tab with an error "No editor descriptor for id org.eclipse.ui.internal.emptyEditorTab" no matter how many times i re-open the file or restart eclipse. Any other ideas on how to open up this file? If not, perhaps you could recomment an alternative program for the time being?

 

*EDIT - I did manage to open it in the 64-bit version (only as text though), but I am pretty sure its because the blackberry plugin isn't installed on it. So I am assuming its a plug-in related issue?

New Developer
Posts: 15
Registered: ‎04-24-2011
My Device: Playbook and curve 6530
My Carrier: MTS

Re: Eclipse Plugin, resource editor does not open

I found that if I close all other source windows then the resource editor window opens okay

New Contributor
Posts: 2
Registered: ‎01-15-2013
My Device: 9300
My Carrier: Indosat

Re: Eclipse Plugin, resource editor does not open

Thank you sir! it works for me too :smileyvery-happy:.

I don't know whose fault is this, either the BB java plugin or eclipse release. Maybe BB developer team could check this issue, altough it seems they are busy with BB10 now :smileyhappy:
New Member
Posts: 1
Registered: ‎02-27-2013
My Device: None
My Carrier: None

Re: Eclipse Plugin, resource editor does not open

Hi, I think this comes from Eclipse. I've tried to file a bug, but just in case : I have got a similar problem: when I close Eclipse (Juno) and re-open it, many times (but not always, and totally randomly), it opens up almost correctly, but all the editors that were opened just show this famous "No editor descriptor for id org.eclipse.ui.internal.emptyEditorTab", instead of the content of the file they (are labelled) refer to. And of course nothing in the logs. FYI, I use the emacs key bindings with CTRL-X CTRLC binded to Exit. I have noticed that when I use this key combination to quit Eclipse, I don't see any DialogBox show 'Saving Workspace' and the problem occurs almost every time, whereas when I use the menu entry File->Exit, I see the DialogBox and most of the time do not have any problem... In case this can help... GM
Developer
Posts: 226
Registered: ‎10-01-2011
My Device: Passport

Re: Eclipse Plugin, resource editor does not open

I have the same issue with Juno, but if I close all the other windowes it works fine. I did a new install of Juno and the core plugin but the issue persists.