Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
ssingh44
Posts: 21
Registered: ‎06-25-2010
My Device: Bold 9700
My Carrier: Rogers

Eclipse Sites Update

So I've been stuck with what seems to be a re-occuring problem on the forums and after trying every proposed solution I'm still no where closer to solving my problem.

 

I downloaded BB Java Plugin for eclipse 1.3, and then have added both:

 

http://www.blackberry.com/developers/jar/3.6/java (recomended in the forums) and

http://www.blackberry.com/go/eclipseUpdate/3.6/java (recommended in the docs)

 

To my eclipse install sites.

 

When I go to try and install from either site, I see a list of available component sdks, and and after selecting in this case 5.0 and going update, the install moves forward, asks for a password (which I've tried entering in both lower and actual case, as per forum suggestions) and then watching the progress bar just freeze.

 

It seems to always have problems fetching the software and freezes after 1-2 megs. However when I take the same URL that eclipss uses I can successfully download the files from the rim servers.

 

The errors varry but most common one I'm recieving is: 

 

An error occurred while collecting items to be installedsession context was:smileysad:profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).Unable to read repository at http://downloads.blackberry.com/upr/developers/javadev/net.rim.ejde.componentpack5.0.0_5.0.0.25.jar.... timed out

 

I've also tried clearing out my temp folder and restarting, and creating a new developer account and using that when prompted to enter the login / password and also having had no success, even after waiting 24 hours.

 

If anyone could please offer some advice as to how to get the component packs working I'd be much obliged as what was supposed to be a product weekend of coding has since fizzled into a frustrating weekend and ill will towards RIM's developer tools.

Please use plain text.
Administrator
MSohm
Posts: 14,241
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Eclipse Sites Update

Do you have a proxy server in your environment?  If so, have you configured it within Eclipse?  What country are you trying to download from?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Contributor
ssingh44
Posts: 21
Registered: ‎06-25-2010
My Device: Bold 9700
My Carrier: Rogers

Re: Eclipse Sites Update

Thanks for the reply, but no proxy server is setup here, just connecting behind a router, (which also doesn't have a proxy setup).
Please use plain text.