Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
JCarty
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Eclipse + System.out.println not working

I am using the latest version of the BB Plugin for Eclipse and I have deleted and reinstalled eclipse twice. However, when I try to debug the console comes up empty.

 

The JDE works great but seems so antiquated so I am trying to get things working in Eclipse. Any help would be greatly appreciated.

 

BB Plugin: 1.0.0.67

BB Component Pack: 4.7.0.46

JDK: 1.6 update 13

JD: 4.7 Final

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Please use plain text.
Developer
JCarty
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Eclipse + System.out.println not working

Anyone? Its a fresh install FYI.
Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Please use plain text.
Developer
JCarty
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: Eclipse + System.out.println not working

Bump.. not one reply? Is everyone using the JDE?
Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful
Please use plain text.
New Developer
Megiddo
Posts: 10
Registered: ‎03-09-2009
My Device: Not Specified

Re: Eclipse + System.out.println not working

I've just checked it on my Eclipse with JDE 4.5 installed, and I see the system outs perfectly fine when I debug. Are you sure the program you have reaches the system out, or weither the right console window is on the foreground?
Please use plain text.
New Developer
subash
Posts: 45
Registered: ‎03-04-2009
My Device: Not Specified

Re: Eclipse + System.out.println not working

It doesnt display any system.out.println message , for me too. I use Eclipse 3.4.1 , BB OS API 4.3.

Please use plain text.
Developer
mantaker
Posts: 1,477
Registered: ‎12-30-2008
My Device: Torch 9810

Re: Eclipse + System.out.println not working

I got the same issue for which I used the workaround like Dialog.inform() for debugging purposes.. I suspect the issue is in BB plugin..Gives different results in different machine.. Maybe RIM missed the usecase testing :lmao:

 

Thanks,

--
Manimaran Selvan
Co-Founder, Tech Lead,
Equity Markets Research Group
Please use plain text.
Developer
gregzav
Posts: 170
Registered: ‎01-17-2009
My Device: 9630

Re: Eclipse + System.out.println not working

Please use plain text.