Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 38
Registered: ‎12-06-2008
My Device: 9530

Eclipse - error running signature tool

Whenever I select "Request Signatures..." from Eclipse, I get a dialog box with the following error:

 

Unable to create temporary directory necessary for this application Directory: xwvIGpcz. Exiting...

 

 

Anyone have a similar problem or know why this might be happening? I've checked the permissions in the various directories (eclipse plugins dir, and the RIM program files dir), and everything seems fine.  Does anyone know where Eclipse might be trying to make this temporary directory? Running the signature tool manually works fine.

Developer
Posts: 38
Registered: ‎12-06-2008
My Device: 9530

Re: Eclipse - error running signature tool

Ok after doing some testing I found that it's trying to create the temporary directory under C:\Windows\System32. I'd rather not make that writeable. Anyone have any idea how to change which temp directory this is using?
BlackBerry Development Advisor
Posts: 15,083
Registered: ‎07-09-2008
My Device: BlackBerry Passport
My Carrier: Bell

Re: Eclipse - error running signature tool

Where is the project (specifically the COD, CSL and CSO files) located that you want to sign?  The temporary directory created should be within that folder.  What version of the BlackBerry JDE Plug-in for Eclipse are you using?
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 38
Registered: ‎12-06-2008
My Device: 9530

Re: Eclipse - error running signature tool

On an entirely separate drive. Eclipse is on F:\Development\eclipse, and my projects and all their associated files are under the same F:\Development subdirectory.  I'm assuming it's defaulting to C:\windows\System32 because that is the location of java.exe.  I think I'm using the current Beta 2 version of the JDE plugin. Eclipse is reporting v1.0.0.50.  

 

Upon further inspection, it must be something project-specific -- because I just created a new project and the signature tool worked fine. I thought I tried that before but I must have just loaded a different project instead of creating a new one entirely. I guess I will just recreate the project(s) causing problems.

 

New Developer
Posts: 2
Registered: ‎04-21-2009
My Device: Not Specified

Re: Eclipse - error running signature tool

I'm having exactly this same problem, except that I did reset permissions on the system32 directory to no avail.  I've recreated my projects and that also hasn't helped.

 

Anyone out there have a solution please?

 

Developer
Posts: 38
Registered: ‎12-06-2008
My Device: 9530

Re: Eclipse - error running signature tool


Jarisha wrote:

I'm having exactly this same problem, except that I did reset permissions on the system32 directory to no avail.  I've recreated my projects and that also hasn't helped.

 

Anyone out there have a solution please?

 


Have you tried reinstalling Eclipse?  I think I may have had to do that as well.

BlackBerry Development Advisor
Posts: 15,083
Registered: ‎07-09-2008
My Device: BlackBerry Passport
My Carrier: Bell

Re: Eclipse - error running signature tool

Please upgrade to the gold release of the BlackBerry JDE Plug-in for Eclipse (1.0.0.67) and post if the issue remains.
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 1
Registered: ‎07-23-2009
My Device: Not Specified

Re: Eclipse - error running signature tool

Hi,

 

I am using  eclipse Version: 3.4.2, Build id: M20090211-1700 installed via BlackBerry_JDE_PluginFull_1.0.0.67.exe downloaded from RIM website.

 

But I still see the exactly same error when I try to request for signatures.

 

I have given full permission to the C:\Program Files (x86)\Eclipse\plugins\net.rim.eide.componentpack4.6.1_4.6.1.27\components\bin\ folder.

 

Do you have any suggestions.

 

Regards

Kiran

New Developer
Posts: 26
Registered: ‎10-23-2009
My Device: Not Specified

Re: Eclipse - error running signature tool

I have experienced this problem as well. I have a project that receives the error "Unable to create temporary directory necessary for this application" whenever I select BlackBerry -> Request Signatures in Eclipse. However, if I delete that project and create a brand new project with just one class, I don't get the error. I have also traced Eclipse and found that it is trying to create a directory in c:/Windows/System32.

 

I've had some other problems that might be related.

 

- frequently when I start Eclipse my project is missing. I need to reimport it

- frequently when I reimport my project, all the project properties are missing (title, version, vendor, resources)

 

I suspect all of these problems are related and caused by interaction with the Subversion eclipse plugin. I'm guessing that certain project files are not being checked into Subversion and are thus lost when I switch between my 2 laptops.

New Member
Posts: 1
Registered: ‎05-11-2010
My Device: BB Bold 9700
My Carrier: Vodacom

Re: Eclipse - error running signature tool

The signiture tool recreates itself in its own directory, eclipse_root/plugins/net.rim.ejde/vmTools,

As well as in the expected location eclipse_root\plugins\net.rim.ejde.componentpack5.0.0_5.0.0.25\components\bin.

 

This folder's permissions may be set to read only. Changing the permissions of this folder (and the SignitureTool.jar file inside) to not "read only" fixed the issue for me.

 

HTH