Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: Eclipse randomly exits after installation of Blackberry plugin/SDK

Running Eclipse Galileo (20090917-0800), BlackBerry plugin (1.1 beta 2), JDK 1.6u17

 

Something defiantly is "happening" because I type the sample and when I get to 'e' nothing is happening still then when I type 'l' Eclipse freezes for about 10 sec, greys out (running Vista), then comes back and everything is fine.

 

No disappearing Eclipse

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
New Developer
tkraus
Posts: 1
Registered: ‎02-03-2010
My Device: BB8900
My Carrier: Vodafone

Re: Eclipse randomly exits after installation of Blackberry plugin/SDK

I have the same problem, using similar environment. I use Windows XP and Eclipse doesn't restat automatically.

 

Eclipse will exit each time I press "." after a BlackBerry class in the Editor.

 

Workaround for me: Disable Auto Activation under Window/Preferences/Java/Editor/Content Asist

 

I hope BlackBerry will provide a fix soon, because this is a very useful and nice feature.

 

 

 

Please use plain text.
New Developer
samcrawford
Posts: 10
Registered: ‎01-12-2010
My Device: 9700
My Carrier: Vodafone UK

Re: Eclipse randomly exits after installation of Blackberry plugin/SDK

Tried downloading the 4.x.x SDKs, as Mark suggested, but it looks like the BlackBerry download site is returning 500 errors to Eclipse. Argh!!!

 

An error occurred while collecting items to be installed
  session context was:smileysad:profile=epp.package.jee, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Collect, operand=, action=).
  Unable to read repository at https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=XXXXXXXXXXXXXXXXXXXXXXXXXXX&dl=...
  Server returned HTTP response code: 500 for URL: https://www.blackberry.com/Downloads/downloadFile;jsessionid=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX.no...

 

Is there a mechanism to install the SDKs manually?

Please use plain text.
Administrator
MSohm
Posts: 14,229
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Eclipse randomly exits after installation of Blackberry plugin/SDK

 


samcrawford wrote:

Tried downloading the 4.x.x SDKs, as Mark suggested, but it looks like the BlackBerry download site is returning 500 errors to Eclipse. Argh!!!

 

An error occurred while collecting items to be installed
  session context was:smileysad:profile=epp.package.jee, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Collect, operand=, action=).
  Unable to read repository at https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=XXXXXXXXXXXXXXXXXXXXXXXXXXX&dl=...
  Server returned HTTP response code: 500 for URL: https://www.blackberry.com/Downloads/downloadFile;jsessionid=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX.no...

 

Is there a mechanism to install the SDKs manually?


 

Please contact devsupport@rim.com with your Developer Zone user name (your email address), IP address, your location and the time you attempted the download for further help on the 500 error.

 

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Developer
balebaron
Posts: 13
Registered: ‎11-24-2009
My Device: Not Specified

Re: Eclipse randomly exits after installation of Blackberry plugin/SDK

@MSohm 

 

I am also seeing the issue of Eclipse crashing randomly when using auto-complete and I am not using the 5.0 SDK. My setup:

 

 

BlackBerry Java Plug-in 
Version:  1.1.1.200911111641-15

 

BlackBerry Java SDK

Version:  4.7.0.53

 

Please use plain text.
New Developer
klrobinson
Posts: 4
Registered: ‎09-25-2008
My Device: Not Specified

Re: Eclipse randomly exits after installation of Blackberry plugin/SDK

All, I have been experiencing the same issue as well and instead of disabling auto-activation I increased the Auto-Activation delay value to 700 and haven't had any problems since.

 

Hope this works for everyone!!!:smileytongue:

Please use plain text.
Contributor
handlez36
Posts: 13
Registered: ‎10-08-2009
My Device: Not Specified

Re: Eclipse randomly exits after installation of Blackberry plugin/SDK

Hi all,

 

I'm late to the game, but I am just now having the same issue.  My setup is as follows...

 

Eclipse IDE For Java Developers (Build id: 20090619-0625)

Eclipse Platform Version: 3.5.0.v20090611a

 

Blackberry Java SDK version: 4.6.1.36 (I have the 5.0 SDK installed, but not used for this specific project)

 

Blackberry Java Plug-in Version: 1.1.2.201003212304-12

 

 

However, I've been running this setup for a while now (since 4/7/2010), and the issue just started happening randomly yesterday (it happened maybe a week ago, but a restart helped).

 

I also tried changing the auto-activation delay to 700.  It took a tad longer to happen, but happened after a while.  I can always seem to recreate this when trying to use the setTime() method on the Calendar class.  Example:

 

Calendar cal = Calendar.getInstance ( TimeZone.getDefault() );

// I have code that creates a Date object

cal.setTIme( Date object ) -- Normally either right when or soon after the period is entered, Eclipse just disappears.

 

Any updates on this issue?

Please use plain text.
Administrator
MSohm
Posts: 14,229
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Eclipse randomly exits after installation of Blackberry plugin/SDK

The issue that I had referred to above was resolved in version 1.1.2.

 

I wasn't able to reproduce the Calendar crash issue you report.  Can you see if this can be reproduced from a fresh workspace?  What version of Windows are you running?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.