Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
marlin
Posts: 1
Registered: ‎09-29-2009
My Device: Not Specified

Error message during update using Application Loader

Hi,

 

Could you please give me a clue, how can I overcome that?

  1. I compiled the application and created alx-file (app version is 1.0).
  2. I ran BlackBerry Desktop Manager (ver. 5.0) and installed the application.
  3. I changed something in my application, re-compiled the application and created new alx-file (app version is 1.1)
  4. I ran BlackBerry Desktop Manager, ran Application Loader, and saw that my application is already shown in Application Loader list (version 1.0). When I tried to install newer version I got the message “This application is not compatible with your device and cannot be loaded”.  Anyway after that the Action in Application Loader window was “Update” and I could update the application.
 How can I update already installed application without error message?  
Please use plain text.
Administrator
MSohm
Posts: 14,421
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Error message during update using Application Loader

Did you also change the application version in the project properties?

 

It's odd that you received that message when trying to upgrade.  Typically that error would appear during the first installation as well.

 

Installing the BlackBerry handheld software for your BlackBerry smartphone on your PC should resolve the issue.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.