Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 239
Registered: ‎07-26-2010
My Device: Z10
My Carrier: Telkomsel

Errors exist in required project(s)?

I checked a project out from SVN, and when I run it, I got this error message:

"Errors exist in required project(s)"

 

There were no hints, so I couldn't figure it out. Of course when I tried to run it in simulator, the application wasn't built at all.

 

Any idea?

Developer
Posts: 16,838
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: Errors exist in required project(s)?

usually you get a red mark in problems, and also markers in the source code.
other possible problems would be errors in the project configuration.
can you compile and run other projects?
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 239
Registered: ‎07-26-2010
My Device: Z10
My Carrier: Telkomsel

Re: Errors exist in required project(s)?

Well I only got 1 red mark, beside the project name. And no other errors.

Previously, I built the project successfully. Then I exported it to zip, because someone asked for the source code.

After that, I got this red mark.

 

Kinda strange... Smiley Frustrated

Developer
Posts: 239
Registered: ‎07-26-2010
My Device: Z10
My Carrier: Telkomsel

Re: Errors exist in required project(s)?

Ah sorry. I turned out that I didn't pay attention enough on Eclipse.

When I clicked the Problem tab, actually there was one error: 

The type PanicAlarmResource is already defined

 

It pointed to PanicAlarmResource.java, which was located somewhere within .locale_interfaces.

So I deleted that file, and refreshed the project. Then it worked.