Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 3
Registered: ‎04-30-2012
My Device: 9800 Torch
My Carrier: None
Accepted Solution

Every Second time Real Device ( 9800 )/ Simulator get hanged .

Every Second time Real Device ( 9800 )/ Simulator get hanged.

 

Below are the Steps.

 

1. Install the applicatio through OTA.

2. Open app. It's work fine.

3. Close App, and try to open Again.

 

Device /Simulator hanged and no operation will be performed, only restart. and from second time onward not abel to launch tha app.

 

please suggest me. how to resolve this issue, 

Developer
Posts: 729
Registered: ‎05-04-2011
My Device: 9700

Re: Every Second time Real Device ( 9800 )/ Simulator get hanged .

Hi @ranjprashant

 

 

It sounds like your application holds the UI event but does not display anything to the user.

 

This is of course just an assumption.

 

If you post some code and give some more details on the problem (like errors from the log), you would probably get better help.

 

E.

New Contributor
Posts: 3
Registered: ‎04-30-2012
My Device: 9800 Torch
My Carrier: None

Re: Every Second time Real Device ( 9800 )/ Simulator get hanged .

Hi thanks for the reply.
I found that only after communicating through sevrer, the device hanging problem occurs.

If i fresh install my application and open and close any number of times device doesn't hang, but after communicating from server only and then close and open hangs the device. and for Simulator, clean.bat required to run.
Developer
Posts: 729
Registered: ‎05-04-2011
My Device: 9700

Re: Every Second time Real Device ( 9800 )/ Simulator get hanged .

It sounds like your communication code runs in the same thread as the UI.

 

Try putting the communication on a separate thread and see if it helps.

 

E.