Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
davejohnson
Posts: 19
Registered: ‎01-04-2009
My Device: Not Specified

Geolocation problems

Ok this is really weird. I am moving a bunch of my Java code from 4.x to work in 5.0+

 

One of the features is geolocation and I cannot get it to work. Doing a simple locationProvider,getLocation(new Criteria()); is timing out... this happens on both phone (Bold 9650) and simulator. GPS is turned on etc and when I load the maps app it shows the "searching for satellites" message...

 

Is there some sort of permissions or something that I might be missing with the widget stuff?

Please use plain text.
Developer
RexDoug
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Geolocation problems

Are you requesting an autonomous GPS fix?  If so, are you outside with a clear view of the sky?

 

Please use plain text.
New Developer
davejohnson
Posts: 19
Registered: ‎01-04-2009
My Device: Not Specified

Re: Geolocation problems

I am using null for the Criteria to the LocationProvider as I did before.

 

On the device I am outside in full view of the sky. On the simulator I am inside :smileytongue:

Please use plain text.
Developer
blueinc
Posts: 109
Registered: ‎12-04-2008
My Device: Playbook, Torch 9800, Storm 9530, Tour 9630
My Carrier: Telus

Re: Geolocation problems

We are using a null Criteria() as well and just had one of our 9650 customers report the same thing. Many others using the 9650, even on the same carrier, are fine. (Well, I assume from their silence that they are not experiencing the same issue)

I've been working with the customer, examining all the permissions and settings and there doesn't appear to be anything different on his phone. I would be VERY interested to find a solution to this ASAP...

TIA

B

PlayBook Apps: Sudoku Pro
Smartphone Apps: Compass | MultiClock
Please use plain text.
New Developer
davejohnson
Posts: 19
Registered: ‎01-04-2009
My Device: Not Specified

Re: Geolocation problems

So I went back to check our 4.x versions of geolocation and I get the same lat / lng = 0.0 when I run it in 4.6 but the simulated location works on 4.6.1, 4.7 and 5.0

 

I am now moving over the working geo code to run as a widget extension and see how that works.

Please use plain text.