Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
sujithravindran
Posts: 261
Registered: ‎08-11-2009
My Device: Not Specified
Accepted Solution

Getting a Tunnel Error For WAP 2.0

Hi ,

 

Im creating an applicaton which is using a secure site im getting json data from there , when i tried the application in the simulator it is working fine ,

 

in device im getting the connection type dynamamically [getting as  " WAP2 trans"] which i concatinated  with the url .

 

but when i tried with the device im getting a tunnel error.

 

what should i do to correct this error .? is there any problem with the carrier .

 

can any help me on this

 

 

Thanks

 

SujithRavindran

 

 

Please use plain text.
Developer
peter_strange
Posts: 19,601
Registered: ‎07-14-2008
My Device: Not Specified

Re: Getting a Tunnel Error For WAP 2.0

tunnel exception sounds like you are using direct tcp, which you might be by accident.  Can you log and tell us the exact connection suffix you are using in your application.  Also can you tell us what carrier you are using and the device and OS level involved.  These might not be relevant, but also might be. 

Please use plain text.
Developer
sujithravindran
Posts: 261
Registered: ‎08-11-2009
My Device: Not Specified

Re: Getting a Tunnel Error For WAP 2.0

Thanks peter, it is now working

Please use plain text.