Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

New Developer
Posts: 1
Registered: ‎11-17-2008
My Device: Not Specified




I have a J2me application running successfully over a number of different makes and models of cellphones. The application makes https connection to my application server.

I need to run this application on blackberry phones as well.

The jar gets installed n my blackberry device but it is unable to connect to the application server.

The application server is hosted over a Public IP.

I am using Black Berry 8820 to test.


I have already compiled the J2Me app with blackberry JDE 4.0.


The application works on the emulator however not on the device. Do we require ny special configuration from our side or from the carrier's side to make it work on the device.


Any help in this regard will be deeply appreciated. 

Posts: 3,951
Registered: ‎07-15-2008
My Device: Not Specified

Re: HELP ME!!!!


Are you getting any exception? Please look at the below article.





Use Search. "Accept Solution" If the problem is resolved.
Posts: 16,893
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: HELP ME!!!!

it would be helpful if you use a self-speaking title. nearly all posts in the forum could bear the "HELP ME!!!!" title. should we distinguish them by the number of exclamation marks?
writing in capital letters is conceived as shouting and considered impolite.
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter