Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Highlighted
New Developer
Posts: 6
Registered: ‎09-05-2009
My Device: Not Specified

Re: How do I get my application to run in the emulator?

Hi,

 

I created a very simple application, following this tutorial:

http://devsushi.com/2007/11/15/getting-started-with-the-blackberry-java-development-environment-jde/

 

Nothing fancy, just a Hello World, and it worked fine when compiled, BUT, I'm also creating a more complex application, nothing crazy, a RSS reader, I has no errors, just normal warnings with classes, packages and stuff not being used (starting to use LWUIT), but, when I compile it it does not appear on the emulator, no errors, no weird things on the Eclipse console, just nothing, I'm trying on an old emulator, the 8300, so no downloads folder here.

 

After this, I copied the "public static void main(String[] args)" functions and required screen from the Hello World to the RSS project, just to add the simple one, but no luck, even when the other app, the Helloworld worked, the RSS doesn't, no errors, just that it doesn't appear on the emulator when I compile it, and this is kind of driving us crazy.

 

Any ideas about this? Clues, suggestions or breadcrums that can lead me to the solution? This issue is really killing the emotion of starting a project with Blackberry, the JDT plugin seems to behalf baked so far Smiley Sad

 

Thanks a lot!

 

Camilo