Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
chamathpali
Posts: 25
Registered: ‎06-15-2013
My Device: 9330
Accepted Solution

How to Choose the correct JDE Version?

Im a little confused here.

Im trying to develop some apps for blackberry phones with OS 6.0 but the Eclipse i download contains the JDE 7.1 version.

https://developer.blackberry.com/java/download/?os=windows#eclipse

 

So if i use it would i be able to create apps for any OS from 5.0 to 7.0 ?

 

Thanks

Developer
peter_strange
Posts: 19,610
Registered: ‎07-14-2008
My Device: Not Specified

Re: How to Choose the correct JDE Version?

See this page:

http://developer.blackberry.com/java/download/

 

The last section entitled:

Installing additional BlackBerry SDK versions

should help you.

Contributor
chamathpali
Posts: 25
Registered: ‎06-15-2013
My Device: 9330

Re: How to Choose the correct JDE Version?

I saw this

" Each additional SDK version will allow you to develop against the respective BlackBerry OS version within your existing Eclipse environment.

It is important that you develop using the right version of the BlackBerry SDK for your intended target market. Applications built against a particular version are forward-compatible with newer BlackBerry Java OS versions, but they are not backward-compatible with older versions. "

 

 

But couldnt understand this "particular version are forward-compatible" ?

 

Thanks

Developer
peter_strange
Posts: 19,610
Registered: ‎07-14-2008
My Device: Not Specified

Re: How to Choose the correct JDE Version?

Putting this another way, is that if you develop something on the OS 6.0 Version, it will run in OS 6.0, OS 7.0 and OS 7.1 devices.  But it won't work with OS 5.0 devices.  Is this any clearer?

Contributor
chamathpali
Posts: 25
Registered: ‎06-15-2013
My Device: 9330

Re: How to Choose the correct JDE Version?

I have started developing in SDK 7.1 so will it work on 6.0 ? 5.0??

Developer
peter_strange
Posts: 19,610
Registered: ‎07-14-2008
My Device: Not Specified

Re: How to Choose the correct JDE Version?

No, in order to work in OS 5.0, you need to use the SDK for 5.0 or earlier.

 

For example, to work in OS 6.0, you can use the SDK for 5.0 or the SDK for 6.0.  You can use the SDK for OS 5.0 because the SDKs are forward compatible to a later (higher number) OS versions.  But SDK 7.1 is not backward compatible with the earlier (lower number) OS levels.

 

Clear now?

Contributor
chamathpali
Posts: 25
Registered: ‎06-15-2013
My Device: 9330

Re: How to Choose the correct JDE Version?

ohh yes than you very much .. 100% clear... :smileyhappy: