Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 14
Registered: ‎11-22-2011
My Device: Bold 9790
Accepted Solution

How to avoid "no debug information found for module net_rim_cldc/net_rim_os"

Hello,

 

Each time I debug on a BB device, I'm getting the following 2 popup errors from Eclipse:

- "no debug information found for module net_rim_cldc"

- "no debug information found for module net_rim_os"

 

I know these messages can be ignored, but I'm tired of those and definitely loose precious time with those errors which are blocking the whole deployment & debug process.

 

What do these errors mean and how to avoid it?

Thanks in advance

Developer
Posts: 16,522
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport

Re: How to avoid "no debug information found for module net_rim_cldc/net_rim_os"

the pre-release notes of the new plugin version said that eclipse will automatically download the debug files for all devices used, so maybe it will resolve these issues.

it is currently not known when the new version will be released.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
Posts: 209
Registered: ‎04-30-2011
My Device: BlackBerry Z10

Re: How to avoid "no debug information found for module net_rim_cldc/net_rim_os"

Hi

 

Try this concept, may be help you.

 

D:\os6\plugins\net.rim.ejde.componentpack6.0.0_6.0.0.30\components\simulator

 

Then Delete your project related file only. 

 

Like pawan.cod, pawan.debug, pawan.cso, pawan.csl, pawan.jar, (all your files only). Be carefull don't delete RIM files.

 

Henceforth, restart your eclipse. Then again run your project.

I think, your issue will be resolved.


Thanks

Pawan


Contributor
Posts: 14
Registered: ‎11-22-2011
My Device: Bold 9790

Re: How to avoid "no debug information found for module net_rim_cldc/net_rim_os"

@simon_hain:

Thanks for the reply. But do these debug file really exist for "net_rim_cldc" and "net_rim_os", and can I download it manually?

I'm getting those errors for all of my devices, but I'm not sure to have installed appropriate simulator version.

In example with a 9800 testing device provided from RIM ("not for sale"):

v6.0.0.246, (Offre 695, Plate-forme 6.4.0.105)

Which simulator version should I download? I can't find such versions from https://www.blackberry.com/Downloads/entry.do?code=060AD92489947D410D897474079C1477

btw the device says no update is available.

 

@pankajace12:

Thanks for the suggestion, I tried it twice but unfortunately it didn't fix those errors.

 

 

Contributor
Posts: 14
Registered: ‎11-22-2011
My Device: Bold 9790

Re: How to avoid "no debug information found for module net_rim_cldc/net_rim_os"

When you debug on devices, do you manually close those popups hundreads of time per week?

Developer
Posts: 16,522
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport

Re: How to avoid "no debug information found for module net_rim_cldc/net_rim_os"

yes, you close them manually.
i rarely debug on the device, for most functionality the simulator is fine.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Contributor
Posts: 14
Registered: ‎11-22-2011
My Device: Bold 9790

Re: How to avoid "no debug information found for module net_rim_cldc/net_rim_os"

The simulator, in our experience doesn't reproduce all the bugs our clients report.

Contributor
Posts: 14
Registered: ‎11-22-2011
My Device: Bold 9790

Re: How to avoid "no debug information found for module net_rim_cldc/net_rim_os"

Indeed the new plugin mostly fixed the problem.

There is just one device for which debug files can't be fond, I wonder why. This is a 9860 evaluation unit (6.1 Offre 579 v6.1.0.60 avril_18_2011_signedPlate-forme 5.0.0.173)

 

-> "no debug information found for module 'net_rim_clcd'. Please ensure that you have installed the simulator package that matches the handheld code you are attempting to debug."

Downloading debug bundle '4daba582' from https://developer.blackberry.com/BBDebugFiles/rest/debug
Download debug bundle failed, status:404

Developer
Posts: 16,522
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport

Re: How to avoid "no debug information found for module net_rim_cldc/net_rim_os"

report it as a bug, seems they don't have the file themselves.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter