Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
MA4312
Posts: 3
Registered: ‎10-24-2008
My Device: Not Specified

Re: How to install Eclipse plug in?

I have installed the complete 500+ MB plugin to a clean copy of eclipse 4.3.0 and imported my project in as a new blackberry workspace. When I try to run/debug the project, the launcher hangs on 'establishing connection' at 40% then fails about 2-3 minutes later with this message:

 

Failed to connect to remote VM. Connection timed out.

 

with the following details:

 

Failed to connect to remote VM. Connection timed out.
org.eclipse.jdi.TimeoutException

 

Any tips on how to fix this? Thanks.

Please use plain text.
Administrator
MSohm
Posts: 14,429
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: How to install Eclipse plug in?

Does the BlackBerry Simulator appear?  Does it show a spinning hour glass and eventually start up and show the home screen?
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Developer
shamusschubert
Posts: 117
Registered: ‎10-22-2008
My Device: Not Specified

Re: How to install Eclipse plug in?

My BB is 4.2.2 which is the same version in the emulator.  It works fine in the emulator but will not load on my actual BB.

 

I am using the dektop tool to try to load the .alx file. 

 

 

 

Eclispse 3.4
JDE 5
Bold/Tour/Storm
Please use plain text.
New Developer
MA4312
Posts: 3
Registered: ‎10-24-2008
My Device: Not Specified

Re: How to install Eclipse plug in?

No the simulator does not show up, eclipse jsut shows the status bar at 40% with the establishing connection message, followed by fail message.

 

I have checked the paths of things like MDS and all that as well and they are all valid, which is why this is so odd.

Please use plain text.
New Developer
MA4312
Posts: 3
Registered: ‎10-24-2008
My Device: Not Specified

Re: How to install Eclipse plug in?

How very strange... I had left the eclipse window open while working back into the RIM JDE, then suddenly the simulator poped up about 10 minutes later. Now when I click run/debug the simulator pops up immediatly.

 

Oh well, thanks anyhow MSohm.

Please use plain text.
New Developer
jacytan
Posts: 88
Registered: ‎11-04-2008
My Device: Not Specified

Re: How to install Eclipse plug in?


MSohm wrote:

Here you go:

 

1.  Start Eclipse.

2.  Select the Help menu and choose Software Updates.

3.  Click on the Available Software tab.

4.  Click on the Add Site button.

5.  Click on the Local button.

6.  Select the site.xml file of the (unzipped) BlackBerry JDE Plug-in for Eclipse.

7.  Click Next through the installation prompts.


 

Hi MSohm,

 

I downloaded BB Eclipse Plugin with JDE Component Pack 4.5. I want to update this to JDE Component Pack 4.3.

I already downloaded the update but i cannot update eclipse. I followed your instructions but then i ran into some trouble.

 

I'm currently using eclipse EUROPA. When i go to Help > Software Updates, i have to choose between "Find & Install" or "Manage Configuration". I tried both and just explored.

 

I arrived at the install menu and i tried two things:

 

1. import site - i tried to browse to look for site.xml that was extracted from the update that i downloaded. But when i click finish, i get an error. it says, "Selected file does not contain update sites bookmarks. please select another file."

 

2. new local site - i specified the URL of the site.xml which was located in D:\...\... But when i click finish, i still get an error. it says, "No features found on the selected sites(s). Choose a different site or site category."

 

I don't know what to do anymore. I have to downgrade my JDE because my device is v4.3. They have to be compatible right?

 

Please help!!! Looking forward to your response.

Please use plain text.
Administrator
MSohm
Posts: 14,429
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: How to install Eclipse plug in?

The version of the component pack must be equal to or lower than your target BlackBerry handheld software version.  However, please note that you can install multiple versions into Eclipse.  To switch between them go to the Window menu, click on Preferences, expand BlackBerry JDE and click on Installed Components.  Can you check there to see if the component pack has already been installed?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Developer
jacytan
Posts: 88
Registered: ‎11-04-2008
My Device: Not Specified

Re: How to install Eclipse plug in?

I think i found the problem. The eclipse blackberry plug-in that i installed is already using Component Pack 4.3.0. I didn't notice it until last week because i looked at the installed components. I assumed it was 4.5.0 because that was the information that is written in the website. Maybe it changed, because i downloaded the plug-in last August. But thanks so much for the reply.

 

I have another question. I want to install many components in eclipse so that i can easily change my environment from 4.2 to 4.3 and vice versa. Since i'm already using 4.3, i need to download component pack 4.2. In the blackberry website, there are two kinds of component packages. One is JDE Component Package 4.2 and the other is eclipse update for component pack 4.2. Which would i have to install for it to be used in eclipse? JDE component package or update for component pack?

 

I'm using eclipse 3.3.1, is v4.2 supported?

Please use plain text.
Administrator
MSohm
Posts: 14,429
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: How to install Eclipse plug in?

Currently the beta release of the BlackBerry JDE Plug-in for Eclipse has component pack plug-ins for BlackBerry handheld software version 4.3.0 and higher.  Version 4.2.0 is not currently supported.
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Developer
jacytan
Posts: 88
Registered: ‎11-04-2008
My Device: Not Specified

Re: How to install Eclipse plug in?

I have another problem. The BlackBerry JDE Plug-in for Eclipse that i have already includes component pack 4.3. I tried to install the component pack 4.5 just to try it out. The installation was successful, and restarted eclipse. But when i tried to look under Window > Preferences > BlackBerry JDE > Installed Components, I could not find the component pack for 4.5. What should I do?

 

FYI: I did not install any BlackBerry JDE at all. Just the BlackBerry JDE Plug-in for Eclipse.

Please use plain text.