Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
paulrowlndapps
Posts: 4
Registered: ‎10-28-2012
My Device: Blackberry Curve 8520
My Carrier: O2
Accepted Solution

Install older BlackBerry SDK versions, Mac

Hi,

 

I have downloaded the latest 7.1 Eclipse JDE for Mac, but am having problems trying to get hold of JDK 5

 

I have a Blackberry Curve 8520 with verion 5.0 of the Operating system.

 

Help -> Instal New Software -> 'Work with..' drop down dosn't have the 'BlackBerry Update Site. as suggested in the RIM website/documentation

 

Does anyone know the easiest way to get hold of an older JRE/JDK?

 

Any help would be very much appreciated.

 

 

Please use plain text.
New Developer
Hassan1
Posts: 8
Registered: ‎10-25-2012
My Device: Blackberry 9790
My Carrier: STC

Re: Install older BlackBerry SDK versions, Mac

[ Edited ]

In your existing Eclipse environment with the BlackBerry Plug-in for Eclipse installed, follow the instructions below:

  1. In the Eclipse Help menu, click Install New Software.
  2. In the Work With drop-down list, click the BlackBerry Update Site.
  3. Expand the BlackBerry Java Plug-in category and select the BlackBerry Java SDK that you want to install.
  4. Click Next.
  5. Accept the terms of the license agreement, and click Finish.
  6. Click Yes to restart Eclipse.

 

as what written here

 

https://developer.blackberry.com/java/download/eclipse?os=mac

Please use plain text.
New Contributor
paulrowlndapps
Posts: 4
Registered: ‎10-28-2012
My Device: Blackberry Curve 8520
My Carrier: O2

Re: Install older BlackBerry SDK versions, Mac

There dosn't seem to be a 'BlackBerry Update Site' in the 'Work with' drop down.

 

There is also nothing that has 'Blackberry' in the 'Available Software sites' either

 

I've also tried manually entering http://www.blackberry.com/go/eclipseUpdate/3.7/java

 

Are you able to see the URL it uses in your environment?

Please use plain text.
Developer
peter_strange
Posts: 19,599
Registered: ‎07-14-2008
My Device: Not Specified

Re: Install older BlackBerry SDK versions, Mac

[ Edited ]

If you look at this page:

 

https://developer.blackberry.com/java/download/eclipse?os=mac

 

There is a link entitled:

Adding the BlackBerry Update site in Eclipse (Mac)

 

Open this and you see these instructions:

"

Notes:

  • If a previous version of the BlackBerry Java SDK 7.1.0 is installed, it should be uninstalled prior to installing the BlackBerry Java Plug-in for Eclipse v2.0.0 with the next version of the BlackBerry Java SDK 7.1
  • If you're using Java 2 SDK, Standard Edition v6.0, obtain Update 16 of the Java 2 SDK v6.0 from the Oracle website before downloading the plug-in using the Eclipse Update Mechanism.

In your existing Eclipse environment, follow the steps below:

  1. From the Help menu, select Install New Software to open the Install window.
  2. Click Add:
    1. In the Add Site dialog, type the URL http://www.blackberry.com/go/eclipseUpdate/mac/java into the location text box and specify BlackBerry Java Plug-in Update Site in the name text box.
    2. Click OK, BlackBerry Update Site appears in the Available Software list.
  3. Select the BlackBerry Java Plug-in item and at least one BlackBerry SDK you want to work with.                 Choose the version of the BlackBerry SDK which ensures that your application is compatible with your intended target market.                 Read more about SDK versions.
  4. Click Next.
  5. Click Next after reviewing the items to be installed.
  6. Check I accept the terms of the license agreement after reviewing the licenses.
  7. Click Finish to begin installation.
  8. After successfully downloading the files, you'll be prompted to restart Eclipse.

"

Hopefully this helps....

 

I would try referencing the page yourself, to make sure you get the update-to-date instructions, rather than those I pasted in here. 

 

Edit: Note that these are the Mac instructions, there are Windows instructions on thi spage:

https://developer.blackberry.com/java/download/eclipse?os=windows 

Please use plain text.
New Contributor
paulrowlndapps
Posts: 4
Registered: ‎10-28-2012
My Device: Blackberry Curve 8520
My Carrier: O2

Re: Install older BlackBerry SDK versions, Mac

Thank you, works a treat.:Rockon:

Please use plain text.