Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
subrat
Posts: 33
Registered: ‎11-23-2009
My Device: Not Specified

Installation help for BlackBerry JDE component for Eclipse version 5.0 beta 5

Hi All,

 

From BlackBerry website I downloaded the net.rim.eide.componentpack5.0.0_5.0.0.14.jar as the Beta 5.0 component package for eclipse.It's not a zip file rather than it's a jar file.

 

Can anyone mention the steps in installing the jar file.

 

I have version 5.0 beta 4 component package installed in eclipse do i need to remove that.

 

Regards

Subrat

Please use plain text.
Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.634 Dev OS, Z30 (STA100-5)-10.3.1.634 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: Installation help for BlackBerry JDE component for Eclipse version 5.0 beta 5

If you look at the Installation guide (currently: http://docs.blackberry.com/en/developers/deliverables/12794/BlackBerry_Java_Plug-in-Installation_and...) and go to "Install an external BlackBerry Java SDK" it should answer your question.

 

It might be easier to add the update site to Eclipse (At the bottom labeled "Installing Eclipse Updates" http://na.blackberry.com/eng/developers/devbetasoftware/javaplugin.jsp), this way you can bring up the Update Manager and install new versions of the Component Pack or update the plugin.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
Developer
hak
Posts: 137
Registered: ‎06-01-2009
My Device: Not Specified

Re: Installation help for BlackBerry JDE component for Eclipse version 5.0 beta 5

I am wondering if you were able to resolve the issue. The file is jar and not zip.

 

When I follow the instructions and add the jar file, I get the error "no repository found at c:\...."  any idea what could be the error ?

Please use plain text.
New Developer
subrat
Posts: 33
Registered: ‎11-23-2009
My Device: Not Specified

Re: Installation help for BlackBerry JDE component for Eclipse version 5.0 beta 5

"no repository found at c:\...." is also observed from my end and If I try to install through BlackBerry Update Site it is taking more than half an hour with installation progress as 32%.

 


Please use plain text.
Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.634 Dev OS, Z30 (STA100-5)-10.3.1.634 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: Installation help for BlackBerry JDE component for Eclipse version 5.0 beta 5

Weird, I've only done it from the update site so I never tried installing it when it was a separate JAR file, I was just reading what I read online.

 

Since it at least seemed to do "something" when you use the update site I would suggest doing it before you go to work/school/out with friends or family and just let it run for a hour or so.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.