Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
iboism
Posts: 5
Registered: ‎12-09-2012
My Device: BlackBerry Bold 9930
My Carrier: Verizon Wireless
Accepted Solution

Installing BB plugin for eclipse

i have been trying to get this pugin to work all day on my already installed version of eclipse but it just kept saying i was missing things so i decided to start fresh and i got rid of my eclipse completely and went to the BB dev downloads page and tried installing the All-in-one eclipse/blackberry package.  after installing it i try to run the shortcut it put on my desktop and it says i don't have a JRE or JDK for eclipse to run in.  my old version of eclipse worked perfectly, so what do i have to do to make this version work??

Please use plain text.
New Contributor
iboism
Posts: 5
Registered: ‎12-09-2012
My Device: BlackBerry Bold 9930
My Carrier: Verizon Wireless

Re: Installing BB plugin for eclipse

NOTE: windows 7 64 bit
Please use plain text.
Contributor
dexy
Posts: 13
Registered: ‎02-26-2010
My Device: Blackberry 9700
My Carrier: Tmobile

Re: Installing BB plugin for eclipse

Maybe try downloading and installing the JAVA sdk. I'm not sure if it comes pre installed with eclipse. I doubt.

http://www.oracle.com/technetwork/java/javase/downloads/java-se-jdk-7-download-432154.html

 

Select the right one for your OS and machine on the download page(bottom)

Please use plain text.
New Contributor
iboism
Posts: 5
Registered: ‎12-09-2012
My Device: BlackBerry Bold 9930
My Carrier: Verizon Wireless

Re: Installing BB plugin for eclipse

just tried that and it says i already have it installed... the error message that pops up when i try opening "BlackBerry Java Plugin 2.0" (which is the shortcut that the Alll-in-one installer gave me) it says:

 

A Java Runtime Environment(JRE) or Java Development Kit(JDK) must be available in order to run Eclipse. No Java virtual machine was found after seraching the following locaitons: C:\Eclipse\jre\bin\javaw.exe 

javaw.exe in your current PATH

 

i'm going to try uninstalling java jdk and installing it in my Eclipse folder

Please use plain text.
Contributor
newton53
Posts: 43
Registered: ‎11-30-2011
My Device: Dev Alpha, 8520
My Carrier: Vodafone

Re: Installing BB plugin for eclipse

[ Edited ]

you'll need a 32 bit JRE and a JDK for BB eclipse plugin to work. JDK can be 32 bit or 64 bit.

If you want to use 32 bit JRE for eclipse only and use 64 bit JRE for your other Java powered apps, you can do the following -

- install 32 bit JRE
- copy the "jre" folder from the installation directory into the "eclipse" folder
- install the 64 bit JRE. it will uninstall the 32 bit JRE first.

 

if you're using a fresh installation and installing the eclipse plugin on it then you'll need a 32 bit eclipse.  I'd recommend Juno.



I've got 99 problems and eclipse is all of them


Twitter

Please use plain text.
New Contributor
iboism
Posts: 5
Registered: ‎12-09-2012
My Device: BlackBerry Bold 9930
My Carrier: Verizon Wireless

Re: Installing BB plugin for eclipse

is there any noticable difference between 32 bit and 64 bit eclipse??

Please use plain text.
Contributor
newton53
Posts: 43
Registered: ‎11-30-2011
My Device: Dev Alpha, 8520
My Carrier: Vodafone

Re: Installing BB plugin for eclipse

[ Edited ]

I reckon the main difference is SWT, the UI library used by eclipse. There are probably a few others, I forgot.

Unless you actually develop eclipse plugins or want "better performance" it shouldn't really matter which eclipse you use. Besides, with BlackBerry Java you're essentially stuck with using 32 bit JRE/JDK, so you can a) either configure your 64 bit eclipse to make BlackBerry projects use 32 bit JRE and have a development environment as stable as a house made of cards, or b) just use 32 bit everything and be done with it.



I've got 99 problems and eclipse is all of them


Twitter

Please use plain text.
New Contributor
iboism
Posts: 5
Registered: ‎12-09-2012
My Device: BlackBerry Bold 9930
My Carrier: Verizon Wireless

Re: Installing BB plugin for eclipse

[ Edited ]

Tried again with the 32 bit everything and it is STILL saying i'm missing things, teh error message says:"installing software" has encountered a problem. An error occured while collecting items to be installed.

-

Unable to read repository at http://downloads.blackberry.com/upr/developers/Win/net.rim.ejde.componentpack7.1.0_7.1.0.10.jar.
Read timed out

 

 

So i tried just installing all the blackberry versions other than the 7.1.0... and it finished in like 20 seconds and works! so is there just a problem on their end with the 7.1 jar??

Please use plain text.
Contributor
newton53
Posts: 43
Registered: ‎11-30-2011
My Device: Dev Alpha, 8520
My Carrier: Vodafone

Re: Installing BB plugin for eclipse

yeah, that's what "Read timed out" indicates. you could try at a later time, it might work.


I've got 99 problems and eclipse is all of them


Twitter

Please use plain text.