Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Bhushannetke
Posts: 8
Registered: ‎02-01-2013
My Device: 9800

Is old Application compatible in Blackberry 10?

Hi All,

 

I have old application compiled in BB 5.0 OS.

How I make it compatible to run application in Blackberry 10.

Need only recompilation? or any thing else..

 

 

Thanks in Advance...

 

Bhushan 

Developer
simon_hain
Posts: 16,282
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport

Re: Is old Application compatible in Blackberry 10?

short answer:
no

you have to port the application, either to html5 or native (or air, or android)
for an introduction to native see http://devblog.blackberry.com/2013/01/port-java-to-cascades-part-1/
(or come to my talk on the JAM in Amsterdam, JAM313)
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter