Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
smunro2009
Posts: 73
Registered: ‎11-02-2009
My Device: Not Specified

JDE 1.1

Hey,

 

I tried to install the JDE 1.1 plugin and met little success with it.  The install seems to expect me to use a temp folder to extract the assembly, but any folder I pick is seemingly refused.  I saw a post about this on Stack Overflow and I've not seen any resolution to this yet.

 

I'm using Windows XP and Java 6.  Instinct tells me it's a problem with the installer itself and not my environment.

 

Has anyone encountered this problem and managed to get the thing installed.  I'm assuming RIM have bothered to test the installer out on various platforms..

Developer
snakeoil
Posts: 15
Registered: ‎03-23-2010
My Device: Storm 9530

Re: JDE 1.1

How are you trying to install it?  Are you doing a fresh install, or upgrading from 1.0?

 

I've had the best success in downloading the full installer both when I originally downloaded the 1.0 release and when I migrated from 1.0 to 1.1 beta 1.  Once I was on 1.1 beta 1 and Eclipse 3.5, the software update worked flawlessly.

 

Its also important that you have the exact version of Eclipse that the plugin is designed for.

 

Here's the link for the full installer, which includes Eclipse:

 

http://na.blackberry.com/eng/developers/javaappdev/javaplugin.jsp

 

It should be a 300+ MB download.

 

Shane

Developer
smunro2009
Posts: 73
Registered: ‎11-02-2009
My Device: Not Specified

Re: JDE 1.1

Cheers for the info Shane.

 

Yeah, I'm using that very link.  I tried to re-download the plugin and it's installed ok, I'm guessing they had fixed the installer recently as the one I used last night was giving me (and a lot of other people) headaches.

 

I'm only testing this at the moment in an attempt to convince my team to shift over to use it.  I need to get a JDE 4.3 app working with this fellow and if all goes well, I should be able to migrate everyone across next  week. I'm sure everyone will welcome being able to use the debugger, which is the main driver for getting this to work.

 

Thanks for getting back to me,

 

Stephen

Developer
smunro2009
Posts: 73
Registered: ‎11-02-2009
My Device: Not Specified

Re: JDE 1.1

Ok, I've got a new problem.  I've installed the plugin ok, but I can't seem to install JDE 4.3 with the plugin.  From what I've read, the new version of the plugin mandates that you use the component packs. I've tried installing the 4.3 component pack, but it requires the older jde plugin.  If you try to install that over the 1.1 plugin, eclipse usefully informs you that you have a newer version of the plugin.

 

The plugin site did say it supported JDE 4.2 upwards.  I'm hoping that we can move forward to version 5.0 eventually, but some of our customers use older devices, and 4.3 is our lowest common denominator at the moment.

 

Has anyone had success getting an older component pack/ or hooking up eclipse to an older JDE using the new plugin?

Developer
challgren
Posts: 70
Registered: ‎05-04-2009
My Device: Blackberry 9800/Blackberry 9530/Blackberry 9700/Blackberry 8530

Re: JDE 1.1

I actually don't see an option for any OS lower than 4.5 to be installed using the Eclipse plugin site.

If you find this post useful please give kudo's
Developer
smunro2009
Posts: 73
Registered: ‎11-02-2009
My Device: Not Specified

Re: JDE 1.1

Hmmm..... When I go to: http://www.blackberry.com/go/eclipseUpdate via eclipse, I get a range of component suites to choose from.

 

On that list I'e got component suites 4.2.1.17 (minimum) up to component pack 5 (5.00.14).  From what I understand, the new plugin wont allow you to access JDE as an external app, you need to make use of the component suites.

 

On the eclipse JVM menu, blackberry setups seem to require a .ee file.  The plugin page definitely mentions supporting lower version of JDE, under technical requirements:

 

Java® 2 SDK, Standard Edition v5.0 (BlackBerry JDE v4.1+)

 

So I'm assuming this plugin should allow me to me use other JDE versions.  Besides, it would be silly to lock into JDE 5.00 as JDE 4.3 is pretty much the lowest common denominator from what I've seen, which explains why we haven't moved forward.

 

It should be a case of selecting the component suites you want and that is the end of it.  This plugin seems to be an awful lot of hassle..

Developer
smunro2009
Posts: 73
Registered: ‎11-02-2009
My Device: Not Specified

Re: JDE 1.1

I've even tried to install the component suites 4.7.0.46 and 4.5.0.16 and it's the same error, it wan't the older JDE plugin.  I seriously wish people would test things properly before releasing.  Seems to be the norm these days were there is no quality control in place and people release things without sufficient testing...</rant>

 

If anyone has solved this problem (aside from abandoning the plugin altogether), I'd be keen to hear about it.

 

 

 

 

Developer
smunro2009
Posts: 73
Registered: ‎11-02-2009
My Device: Not Specified

Re: JDE 1.1

Ok, I've given up on this and will simply stick to using the older plugin without the debugger...

 

Seriously, I can understand there will be bugs in the finished product, but how can a use case like configuring the plugin to use an older JDE be overlooked???  That's a pretty high level thing.  Your not making it easy for developers to work on this platform, and that 's going to come back on you eventually. I wish we could drop blackberry altogether and move to Android or something with better tool support as this is unreal.  Guys, not everyone working with JDE is doing research in academia so you can hardly expect certain clients to embrace the latest blackberry devices so we can start working with JDE 5.0.

 

Mobile development is a gold mine and I can understand cutting corners to get  into the ring early, but the best place to start is to win over developers and show them that you've got a good platform to work with and you cater for developers by giving them the tools they need to do a good job.  From that you'll see good products emerge.  From my own point of view, you are scaring away developers, which is a very sad state of affairs.  If you have any upcoming meetings in the future, this would certainly be on my agenda for discussing.

Developer
smunro2009
Posts: 73
Registered: ‎11-02-2009
My Device: Not Specified

Re: JDE 1.1

Ok,

 

Looks like I'm using the wrong update site.  I should be using: http://www.blackberry.com/go/eclipseUpdate/3.5/java as it says on the actual page.  So I'm not seeing JDE 4.5 as the minimum component suite available to me.  However, my point still stands.  The site claims that the minimum re is JDE 4.1, yet only 4.5 is allowed.

 

Developer
snakeoil
Posts: 15
Registered: ‎03-23-2010
My Device: Storm 9530

Re: JDE 1.1

Yeah, I can confirm that the online update site only allows access back to the 4.5 jde.  Bummer that your requirement is a 4.3 app.

 

To defend RIM here, the 1.1 update is a beta build, so there are a lot of issues with it.  1.1.1 was a lot worse than 1.1.2, so they are getting better.  Maybe by the time they are done they will be supporting 4.3 and earlier.   Not fast enough if you have a client that needs something done ASAP, likely. :smileysad: