Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
darkhornet
Posts: 4
Registered: ‎12-18-2008
My Device: Not Specified
Accepted Solution

JDE not starting up.

I am using Windows XP via Parallels on a Mac.  I've got the BlackBerry JDE 4.7.0 installed, along with Java JDK 1.6.0.  I've updated my environment path to include the bin directory of the JDK.  I've restarted my windows and confirmed the path is working by trying to open a dll from that directory without specifying a path.  However, when I try to open the JDE, it appears to open a commant prompt and run something, but then that window closes and nothing else happens.  It happens too quickly for me to see what messages are coming up in the consule window.  For reference, this same behavior happens when trying to start the standalone MDS, but I can open a simulator for a phone fine.


Any ideas would be appreciated, and I'll try to provide any other information that could help.

 

Thanks!

Please use plain text.
Developer
RexDoug
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: JDE not starting up.

I suggest that you run the IDE.BAT from the command line and see what is being reported.

 

My guess is either environment "path" issues, or the JRE is the wrong version for the 4.7 JDE.

 

 

Please use plain text.
New Developer
darkhornet
Posts: 4
Registered: ‎12-18-2008
My Device: Not Specified

Re: JDE not starting up.

Thanks for the feedback.  Here's my run of the ide.bat:

C:\Program Files\Research In Motion\BlackBerry JDE 4.7.0\bin>ide.bat C:\Program Files\Research In Motion\BlackBerry JDE 4.7.0\bin>start javaw -Xmx256 M -DRIM_RUNTIME=..\lib -DRIM_BIN=..\bin -jar IDE.jar C:\Program Files\Research In Motion\BlackBerry JDE 4.7.0\bin>

 

Nothing else seems to get started as a result, and it gives me no error messages.  Do you know which version of the JRE is needed?  I seem to be up to six, but I don't think anything for my JRE is in my paths.

 

Please use plain text.
New Developer
darkhornet
Posts: 4
Registered: ‎12-18-2008
My Device: Not Specified

Re: JDE not starting up.

Awesome... got it working.  Apparently what I missed was there was an older JRE that was in the path from an old Oracle install.  I added the new JRE before it in my path, and viola!  I have an opening JDE.  Thanks a lot!
Please use plain text.