Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
andrewl41
Posts: 20
Registered: ‎05-12-2010
My Device: 8520

JRE 4.3.0

Hi All

 

I need to update my app, currently written for 4.6.1 and up to support 4.3.0.  

 

Could someone point me to the right place on the site to get the required JRE for the eclipse plugin?  I can't seem to find it anywhere.

 

Thanks

 

 

Andrew

 

 

Developer
peter_strange
Posts: 19,610
Registered: ‎07-14-2008
My Device: Not Specified

Re: JRE 4.3.0

I believe the earliest supported JRE is 4.5.  If you looking to develop stuff for an OS that is earlier than that, you will need to use the JDE.  However I think all 4.3 devices can be upgraded to 4.5.  I would recommend that you do this rather than develop in 4.3.

Contributor
andrewl41
Posts: 20
Registered: ‎05-12-2010
My Device: 8520

Re: JRE 4.3.0

Thanks for the reply

 

I've now found a site that provides the 4.3.0 components package in eclipse format.  For anyone looking for the same thing in future, it's here for now at least:

 

http://na.blackberry.com/eng/developers/devbetasoftware/jar/3.5/java

 

Sadly, I can't tell my client to upgrade all their 000's of 8120's that are still running 4.3.0 so I have no choise but to support this.  That's what they are paying for so that's what I need to develop for.

 

It's very poor that BB don't continue to officially offer resources like this.  They are supposed to be enterprise friendly and we all know big organisations are often slow to upgrade or move forward when it comes to technology.  Just look at IE 6 usage as another example.  

 

 

Contributor
martinpas
Posts: 22
Registered: ‎10-03-2011
My Device: 8520

Re: JRE 4.3.0