Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
talha_khan
Posts: 4
Registered: ‎02-22-2011
My Device: Bold 9000

JVM Error 104 - Uncaught: Error

Hi,

 

I have a strange problem, I'm getting a JVM Error 104 - Uncaught: Error when I debug my application more than once. It works absolutely fine when I debug it for the first time but if I debug it again without closing the simulator I get this error.

 

I've only recently started having this problem and have tried appending /ignore-error=104 to the simulator command line, have also tried cleaning the simulator and all. I don't see any problem when I run the same code on the device, it's just on the simulator. I can of course click continue from there and it works fine from there but I'm just curious as to why this is happening and if there may be something wrong with the code that I am not able to figure out.

 

 

Thanks,

Talha

Please use plain text.
Developer
simon_hain
Posts: 15,947
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: JVM Error 104 - Uncaught: Error

check the stacktrace of the exception. if it was thrown by a rim app you can ignore it as it will most likely not affect a real device.

if it is thrown by your own app you should catch it.

104 means uncaught exception -> catch it.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
New Contributor
talha_khan
Posts: 4
Registered: ‎02-22-2011
My Device: Bold 9000

Re: JVM Error 104 - Uncaught: Error

Simon, I don't get a stack trace when I debug it for the second time. It just gives that error within seconds of clicking debug, the stack is empty at that point.

Please use plain text.