Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
amiejoye
Posts: 10
Registered: ‎10-16-2008
My Device: Not Specified
Accepted Solution

KeywordFilterDemo error

I'm new to Blackberry development with Java.  I am getting this error when I run the KeywordFilterDemo sample.  Can someone tell me how to fix it?  Thanks!

 

Starting KeywordFilterDemo
VM:LINK KeywordFilterDemo
Class 'net.rim.device.api.ui.component.KeywordProvider' not found.
Linker error: 'VerifyError' for KeywordFilterDemo
Error starting KeywordFilterDemo: Class 'net.rim.device.api.ui.component.KeywordProvider' not found.

Please use plain text.
Administrator
MSohm
Posts: 14,421
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: KeywordFilterDemo error

Are you using a version of the BlackBerry JDE that is supported by your BlackBerry device?

 

What Is - Appropriate version of the BlackBerry JDE
Article Number: DB-00537

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800901/What_Is_-_Appr...

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Developer
amiejoye
Posts: 10
Registered: ‎10-16-2008
My Device: Not Specified

Re: KeywordFilterDemo error

Thanks!

 

I think that is the problem.  Do you know if there is a version of the KeywordFilterDemo for the Curve 8310 or if the new version will load to the 8310?

Please use plain text.
Administrator
MSohm
Posts: 14,421
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: KeywordFilterDemo error

The KeywordFilterField was added in version 4.5.0 of the BlackBerry API set.  Please check your carrier's web site to see if they offer BlackBerry handheld software version 4.5.0 for your BlackBerry Curve.

 

Note that this means you'll need to build the application using the version 4.5.0 BlackBerry JDE.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.