Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
MatthewPierce
Posts: 9
Registered: ‎03-31-2012
My Device: All

MS VC2008 Runtime not found...

Okay, so I finally got Eclipse set-up with the BlackBerry plugin, and now when I start up I get this message:

 

Missing VC2008 Runtime...

 

Microsoft Visual C++ 2008 runtime redistributable package is not found.  this is required for proper functionality of browser in the BlackBerry SDK 7.0.0.33 simulator.  The required package can be installed from:  MS VC2008 Redistributable Package

 

I get three pop-up windows, one for the above SDK and two more for 7.1.0.7 and 6.0.0.43.  So, I did as I was told and clicked on the link.  After I downloaded the .exe and ran it, turns out I already have VC2008 RP installed, which I already suspected.  So, I uninstalled it re-installed, and then ran Eclipse again.  Same three pop-up warnings.  What gives, why am I getting this error when I have the required package installed?

 

While I have your attention, if in fact I do, there are also some errors on the BB SDK download website.

 

https://bdsc.webapps.blackberry.com/java/download/eclipse

 

The line that reads:

 

"If you're using Java 2 SDK, Standard Edition v6.0, obtain Update 16 of the Java 2 SDK v6.0 from the Oracle website before downloading the plug-in using the Eclipse Update Mechanism."

 

Has a link supposedly to the Oracle website.  Guess what, it goes to http://java.sun.com/ which does not work.

 

Additionally, because I've been having so many issues getting the BB SDK to work with my Eclipse 3.7.2, I decided to just toss it and go with this option:

 

"Don't have an existing Eclipse environment? No problem, you can download the full installer below, which includes Eclipse 3.6, BlackBerry Plug-in for Eclipse 1.5 and the BlackBerry 7.0 SDK conveniently packaged in a single installer."

 

Following the steps there you end up downloading an Akami Installer that, after installing itself does absolutely nothing.  No Eclipse 3.6, no SDK...nada.

 

I have three utilities that are up and ready to go for iPad and Android.  I would really, really, like to get them converted and ready for release on BlackBerry simultaneously, but seeing how I've been trying to get the BB SDK working on my machine for three days now, and failing, I'm almost to the point where I'm ready to dump my desires to support BlackBerry. 

 

Help me out here guys, please.  This should not be this hard.

Please use plain text.
Administrator
MSohm
Posts: 14,569
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook

Re: MS VC2008 Runtime not found...

What version of Windows are you using?  Is UAC enabled?

 

When you say the full installer "does nothing" do you mean clicking on it doesn't launch the installer or does the install wizard die part way through?  If you get an error, what is it?

 

Thanks for the notice on the link on the website.  I'll get that fixed.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Contributor
MatthewPierce
Posts: 9
Registered: ‎03-31-2012
My Device: All

Re: MS VC2008 Runtime not found...

What version of Windows are you using?  

-Windows 7 Professional 64-bit

 

Is UAC enabled?

-Running Eclipse as Administrator, UAC should not be an issue.

 

When you say the full installer "does nothing" do you mean clicking on it doesn't launch the installer or does the install wizard die part way through?  If you get an error, what is it?

-Akami installs and then nothing else happens.  No download of your version of Eclipse 3.6, no messages, no reported errors, nothing.

 

Please use plain text.
Administrator
MSohm
Posts: 14,569
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook

Re: MS VC2008 Runtime not found...

Which browser are you using?  Have you tried more than one?  The installer should start downloading after the Akamai browser plug-in has been installed.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Contributor
MatthewPierce
Posts: 9
Registered: ‎03-31-2012
My Device: All

Re: MS VC2008 Runtime not found...

Firefox 11.

 

Any ideas about why I am getting the message about the VC2008 issue?

Please use plain text.
Administrator
MSohm
Posts: 14,569
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook

Re: MS VC2008 Runtime not found...

There are different versions of it.  Possibly our tools are looking for a different one than what you have.  Try to install a 7.1 simulator and the VC 2008 runtime that is bundled with it.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Contributor
MatthewPierce
Posts: 9
Registered: ‎03-31-2012
My Device: All

Re: MS VC2008 Runtime not found...

I uninstalled my current VC2008, uninstalled the 7.1 simulator that was already installed  and then re-installed 7.1 simulator.  When Eclipse restarted I got the same error (for all three simulators I referenced in first post).  I then clicked on the link that was in the pop-up, downloaded the version of VC2008 that was linked there (http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=29), installed and restarted Eclipse.  Still getting same error.

 

So, back to square one.

 

Also, while poking around I found two errors under Window>Preferences>BlackBerry Java Plug-in>Warnings I got these two nice little pop-ups:

 

Error - BlackBerry Java Development Environment
Cannot find RIMIDEWin32.dll.  this is a required component of the IDE.

Error - BlackBerry Java Development Environment
Cannot find RIMUsbJni.dll.  Without this dll the IDE cannot connect to USB enabled handhelds.
Add RIMUsbJni to java.library.path.

 

This just keeps getting better.

Please use plain text.
Visitor
jschang
Posts: 1
Registered: ‎04-05-2012
My Device: developer

Re: MS VC2008 Runtime not found...

I am having the exact same issue on a Windows 7 64-bit machine.  Eclipse version is Indigo.  I have tried installing both x86 and x64 versions of MS VC2008.

Please use plain text.
New Contributor
MatthewPierce
Posts: 9
Registered: ‎03-31-2012
My Device: All

Re: MS VC2008 Runtime not found...

Whew...I thought it was just me.

Please use plain text.
Administrator
MSohm
Posts: 14,569
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook

Re: MS VC2008 Runtime not found...


MatthewPierce wrote:

 

Error - BlackBerry Java Development Environment
Cannot find RIMIDEWin32.dll.  this is a required component of the IDE.

Error - BlackBerry Java Development Environment
Cannot find RIMUsbJni.dll.  Without this dll the IDE cannot connect to USB enabled handhelds.
Add RIMUsbJni to java.library.path.

 

This just keeps getting better.



These are caused if you have a 64 bit JDK installed.  Our development tools require a 32 bit JDK.  Please install that and configure it as your default JDK (path and/or JAVA_HOME environment variables).

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.