Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 3
Registered: ‎02-23-2010
My Device: curve

Making sure your app is compatible with a large variety of blackberrys

if I write my app for the tour or curve would the application be compatible with either, or would there need to be a separate application for each?

Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Making sure your app is compatible with a large variety of blackberrys

It's all dependent on the OS level.

 

You can deploy an application on a device that has a OS level >= the JDE level used to create it.

 

You cannot deploy on an OS level less than the JDE level.

 

So, pick a JDE level that matches up with the oldest OS level that you plan to support. Our "base" is currently 4.2.1, but we also have seperate builds for 4.5 and 4.7.

 

 

 

Developer
Posts: 587
Registered: ‎01-19-2010
My Device: BOLD 9700 OS5.0.0.x on Rogers Canada
My Carrier: Rogers

Re: Making sure your app is compatible with a large variety of blackberrys

If you make a 4.7 build it will be available on most of the recent devices. If you plan to back-support older devices, you should use 4.2 or 4.5. The OS, however, should be consistent across all device types, so if it works on the curve, chances are it should work on the Bold, etc as well. The exception is the Storm -- the touch-screen and orientation detection add new levels of complexity.

----------------------------------------------------------------------------
chown -R us ./base
~J!NX