Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
mreed
Posts: 1,041
Registered: ‎07-16-2008
My Device: ಠ_ಠ

Re: Multiple JDE's / JDK's + Simulators HELL !!

[ Edited ]

You shouldn't need multiple jdk versions or doctored batch files. I have JDE versions 4.0.0 through 4.7.0 and only use jdk1.6.0. Even though I use eclipse and not the JDE's directly, I do not have any problems with the simulators or MDS. If there is a problem with the -4.2.1 signature tools, try copying one from 4.3.0+ (4.3.0 started using the passwd through command line I believe).

 

The environment variables I have are:

JAVA_HOME: C:\tools\Java\jdk1.6.0_06

Added to beginning of PATH: %JAVA_HOME%\bin;%JAVA_HOME%\jre\bin;

Message Edited by mreed on 12-29-2008 10:49 AM
Developer
Posts: 5,339
Registered: ‎09-20-2008
My Device: ***
My Carrier: ***

Re: Multiple JDE's / JDK's + Simulators HELL !!

I agree with mreed.

 

I have one JDK 1.6 installed and there are JDE from 4.0 to 4.7 on my computer.

 

All of them work just fine.

 

Just specify PATH environment variable to let your java/bin folder accessible from outside.

 

And that's it. Nothing more.

Developer
Developer
gtj
Posts: 319
Registered: ‎07-20-2008
My Device: Not Specified

Re: Multiple JDE's / JDK's + Simulators HELL !!

The only "gotcha" is that if you're running a 64-bit OS, you'll need the 32-bit JDK because the JDE has 32-bit native libraries.