Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 107
Registered: ‎05-26-2011
My Device: Torch
My Carrier: Mobilink

Need OpenGL ES 1.0 or 1.1 samples

Hi,

 

I need to develop a game foor BB using openGL ES.

I have been looking arround  for a month some sample material BB has provided bt found nothing.

I have gone through 3D cube and 2D triangle examples that BB provided but i want more than that ..

Actually i am new to openGL ES so have problem in drawing simple objects on canvas.

I also need to know how to detect events on the canvas objects.

Can any one help me getting some opengles sample BB apps, tutorials or guides?

 

thanks

Developer
Posts: 107
Registered: ‎05-26-2011
My Device: Torch
My Carrier: Mobilink

Re: Need OpenGL ES 1.0 or 1.1 samples

any one there?

Developer
Posts: 60
Registered: ‎05-04-2011
My Device: Torch 9800, Bold 9700, Curve 9380
My Carrier: None

Re: Need OpenGL ES 1.0 or 1.1 samples

Actually I am trying to run the sample OpenGL application on 6.0 BB simulator.

But the app could not launch. Before that a dialog comes saying 'This device does not support OpenGL, exiting OpenGL Demo application'.

So I want to know, from which version the support of OpenGL is on the BB ?
Developer
Posts: 107
Registered: ‎05-26-2011
My Device: Torch
My Carrier: Mobilink

Re: Need OpenGL ES 1.0 or 1.1 samples

check here

 

http://supportforums.blackberry.com/t5/Java-Development/OpenGL-ES/m-p/566081/highlight/true#M116124

Developer
Posts: 60
Registered: ‎05-04-2011
My Device: Torch 9800, Bold 9700, Curve 9380
My Carrier: None

Re: Need OpenGL ES 1.0 or 1.1 samples

Hi,

Link provided by you is not accessible,
Page Not Found

Thanks
Developer
Posts: 107
Registered: ‎05-26-2011
My Device: Torch
My Carrier: Mobilink

Re: Need OpenGL ES 1.0 or 1.1 samples

copy and paste it on your browser thn open it.

 

 

Developer
Posts: 60
Registered: ‎05-04-2011
My Device: Torch 9800, Bold 9700, Curve 9380
My Carrier: None

Re: Need OpenGL ES 1.0 or 1.1 samples

Hi,

Actually I do have only one simulator i.e. 9800. that is why the app is not running.

Is the openGL possible only from 7.0+ onwards ?
Developer
Posts: 107
Registered: ‎05-26-2011
My Device: Torch
My Carrier: Mobilink

Re: Need OpenGL ES 1.0 or 1.1 samples

please create a  seperate thread for your issue.

 

you can fid ur answers here

http://en.wikipedia.org/wiki/OpenGL_ES