Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
FrugalHorn
Posts: 27
Registered: ‎04-09-2009
My Device: Not Specified

Not found symbol error - "EventInjector $KeyCodeEvent.<init>"

Greetings!!

 

I am using a JDE4.5.0 and Pearl 8310 for testing. I have used event injection in my application.

 

I install the app on the device and click to edit configuration, device throws an error Symbol ‘EventInjector $KeyCodeEvent.<init>’ not found.

 

I have ensured,

1. The code is signed.

2. App is given appropriate permissions before invoking it.

3. The .csl file has an entry "52525400=RIM Runtime API".

 

Everything works fine in the simulator but no good on device. Please can someone pass a clue as to what must have been wrong?

 

Thanks,

-/FH

Please use plain text.
Developer
rafo
Posts: 507
Registered: ‎07-15-2008
My Device: Not Specified

Re: Not found symbol error - "EventInjector $KeyCodeEvent.<init>"

[ Edited ]

Seems that JDE version is newer than your actual device OS software version number.

 

Check JDE version via menu: Help - About

 

On device go to Options - About

 

Now compare device OS version and JDE (RIM API) version.

 

device OS version has to be equal or bigger than JDE version you used to compile the application.

Message Edited by rafo on 14-05-2009 12:25 PM
----------------
if your issue solved set "Solution" mark at the relevant post
Please use plain text.
Developer
rafo
Posts: 507
Registered: ‎07-15-2008
My Device: Not Specified

Re: Not found symbol error - "EventInjector $KeyCodeEvent.<init>"

The error occured because there is an unresolved reference to a class/method in actual device OS.

 

Your application contains a reference to a class/method, but this reference cannot be resolved by actual device OS.

 

The reason I described in previous post.

----------------
if your issue solved set "Solution" mark at the relevant post
Please use plain text.
New Developer
FrugalHorn
Posts: 27
Registered: ‎04-09-2009
My Device: Not Specified

Re: Not found symbol error - "EventInjector $KeyCodeEvent.<init>"

Thank rafo.

 

I had learnt what you are suggesting from this page:

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800738/800901/What_Is...

 

In my case the,

 

4.5.0.7   is the JDE version and

4.5.0.44 is the Device version.

 

So thanks but the issue seems to be somewhere else.

 

-/FH

Please use plain text.
Developer
rafo
Posts: 507
Registered: ‎07-15-2008
My Device: Not Specified

Re: Not found symbol error - "EventInjector $KeyCodeEvent.<init>"

[ Edited ]

The problem is as I described.

 

You have to have at least 4.5.0.7 or bigger version of your device software to run code compiled on JDE 4.5.0.7

 

4.5.0.44 is older than 4.5.0.7

 

and therefore you get error message.

Message Edited by rafo on 14-05-2009 01:18 PM
----------------
if your issue solved set "Solution" mark at the relevant post
Please use plain text.
Developer
rafo
Posts: 507
Registered: ‎07-15-2008
My Device: Not Specified

Re: Not found symbol error - "EventInjector $KeyCodeEvent.<init>"

You need either to use JDE 4.5.0.44 or older or update your device software to 4.5.0.7 or newer.
----------------
if your issue solved set "Solution" mark at the relevant post
Please use plain text.
New Developer
FrugalHorn
Posts: 27
Registered: ‎04-09-2009
My Device: Not Specified

Re: Not found symbol error - "EventInjector $KeyCodeEvent.<init>"

I'm failing to understand something here.

 

How can 4.5.0.44 be older than 4.5.0.7? Does RIM name the versions number backwards? With that analogy is 4.5.0 older than 4.4.0?

 

 

Please use plain text.
Developer
rafo
Posts: 507
Registered: ‎07-15-2008
My Device: Not Specified

Re: Not found symbol error - "EventInjector $KeyCodeEvent.<init>"

[ Edited ]

4.5.0.7 semantically is the same as 4.5.0.70

 

Just add zero to align the number.

 

4.5.0.7 (4.5.0.70) is newer than 4.5.0.44

 

 

Message Edited by rafo on 14-05-2009 01:35 PM
----------------
if your issue solved set "Solution" mark at the relevant post
Please use plain text.
Developer
rafo
Posts: 507
Registered: ‎07-15-2008
My Device: Not Specified

Re: Not found symbol error - "EventInjector $KeyCodeEvent.<init>"

[ Edited ]

I agree that RIM provides very strange approach in version numbering without number alignment.

 

From logical point of view 0.44 is less than 0.7

 

and therefore 0.7 is bigger (newer) than 0.44 version.

Message Edited by rafo on 14-05-2009 01:40 PM
----------------
if your issue solved set "Solution" mark at the relevant post
Please use plain text.