Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Developer
mb1
Posts: 318
Registered: ‎05-26-2009
My Device: Not Specified

OS6.0 - both touch and keyboard - compatibility mode - minimum JDE version to compiile.

Hi,

 

Are there any guidelines for what is the minimum JDE version that should be used to compile apps intended to run on BB OS 6.0?

 

I am asking this because 9800 has a touch screen as well as a qwerty keyboard.

 

I'd really appreciate a response.

 

Thanks,

 

--MB

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: OS6.0 - both touch and keyboard - compatibility mode - minimum JDE version to compile.

I doubt it. The Storm could still run apps from 4.2, it ran them in compatibility mode. The 9800 will probably do the same thing but instead of a virtual keyboard it will use the physical keyboard.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
Developer
CMY
Posts: 1,122
Registered: ‎02-10-2009
My Device: 8130 / 8350 / 9530 / 9550 / 9850 / PlayBook
My Carrier: Verizon

Re: OS6.0 - both touch and keyboard - compatibility mode - minimum JDE version to compile.

I agree, the bigest issue I see is if both input methods are active when the keyboard is out, or does the keyboard have priority.

Please use plain text.
Contributor
bpearce
Posts: 27
Registered: ‎06-08-2010
My Device: iPhone 4 - Sorry RIM
My Carrier: AT&T

Re: OS6.0 - both touch and keyboard - compatibility mode - minimum JDE version to compile.

I too am interested in this, as I am just finishing up a v5 project.  I will undoubtedly have to modify it to work well on devices with touch and keyboard, especially since I have no idea what it will do to things like: VirtualKeyboard.isSupported()

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: OS6.0 - both touch and keyboard - compatibility mode - minimum JDE version to compile.

I don't think there is a VirtualKeyboard on the 9800. I haven't had a lot of time playing around with the 9800 simulator but you can't "close" the keyboard so I don't know how to test if there is a VirtualKeyboard or not.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
Developer
mb1
Posts: 318
Registered: ‎05-26-2009
My Device: Not Specified

Re: OS6.0 - both touch and keyboard - compatibility mode - minimum JDE version to compile.

I just saw the video demo at crackberry. And I can see the virtual keyboard.

Please use plain text.
Developer
Developer
CMY
Posts: 1,122
Registered: ‎02-10-2009
My Device: 8130 / 8350 / 9530 / 9550 / 9850 / PlayBook
My Carrier: Verizon

Re: OS6.0 - both touch and keyboard - compatibility mode - minimum JDE version to compile.

There is a virtual keyboard that is shown in this youtube video of an actual device.

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: OS6.0 - both touch and keyboard - compatibility mode - minimum JDE version to compile.

Yes I saw a picture of one a little bit ago.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
sreid55
Posts: 41
Registered: ‎09-28-2009
My Device: Not Specified

Re: OS6.0 - both touch and keyboard - compatibility mode - minimum JDE version to compile.

You can close and optn the virtual keyboard on the 9800 simulator via menu item Simulate->Open Slider

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: OS6.0 - both touch and keyboard - compatibility mode - minimum JDE version to compile.

Thanks, I see it now.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.