Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
editormax
Posts: 133
Registered: ‎07-20-2009
My Device: Not Specified

OpenGL draw 2-D triangle with nothing on white screen

Hi all,

  I was copied the sample code of  Rendering a multi color 2-D triangle. After I compile it and run simulator, it just display a white screen only. Anyone can help?

Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: OpenGL draw 2-D triangle with nothing on white screen

I'm guessing you are talking about 

http://docs.blackberry.com/en/developers/deliverables/11942/CS_OpenGLTest_952941_11.jsp.

 

What simulator are you running? OpenGL ES is only supported on on the Storm (simulator: 9500/9530/9520/9550, real: 9520/9550) right now.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Developer
editormax
Posts: 133
Registered: ‎07-20-2009
My Device: Not Specified

Re: OpenGL draw 2-D triangle with nothing on white screen

Yes you are right, I am trying this sample.

 

I have try simulator 9550.....But it only print a white screen to me!

 

Do you have any idea?

Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: OpenGL draw 2-D triangle with nothing on white screen

Did you copy it straight from the webpage, by method/line/something like that, or did you read the code and copy it by memorizing small snippets and typing it?

 

If the first one then I have no idea because it should work just fine.

If the other two then look closely for differences between the webpage and your code. It might be an error in initialization or drawing.

 

*Light bulb* Wait, I actually remember getting this. Does the screen do a quick flash when the app starts up and a white screen pops up? If not then it might be what I said before, otherwise try updating to Eclipse plugin 1.1 (that was my problem though occasionally it worked with plugin 1.0).

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Developer
editormax
Posts: 133
Registered: ‎07-20-2009
My Device: Not Specified

Re: OpenGL draw 2-D triangle with nothing on white screen

After i update the the new eclipse plugin it still not work, Do you have more idea?

 

Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: OpenGL draw 2-D triangle with nothing on white screen

Sorry, based on everything you said it should be working. One idea is to turn off hardware acceleration (if it is enabled) on the simulator (just search the menus, you'll find it).

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Developer
editormax
Posts: 133
Registered: ‎07-20-2009
My Device: Not Specified

Re: OpenGL draw 2-D triangle with nothing on white screen

Thanks first, I have checked that acceleration is aready.


Do you still have anymore idea?

Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: OpenGL draw 2-D triangle with nothing on white screen

Unfortunately no, from what you have said it should work but since it isn't I have nothing I cannot come up with anything else.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
New Contributor
chriz
Posts: 5
Registered: ‎03-12-2010
My Device: 9700

Re: OpenGL draw 2-D triangle with nothing on white screen

Hi,

 

i am tying the OpenGL example, it work fine with 9550 simulator but the same code don't work with 9700.

When i run the app on the 9700 the method GLUtils.isSupported() return true but when i call _egl.eglGetConfigs(_eglDisplay, null, 0, num_config); the num_config return that there is 0 config availlaible ? Does the Bold 9700 really support opengl ?

 

 

Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: OpenGL draw 2-D triangle with nothing on white screen

Call GLUtils.isSupported() to find out OpenGL ES is supported.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.