Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 300
Registered: ‎03-12-2009
My Device: Not Specified

Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

I'm tryin to build an app using the new BBM6 SDK, but when I try to preverify the .jar file provided i get the following error:

 

preverify -classpath "C:\eclipse\plugins\net.rim.ejde.componentpack6.0.0_6.0.0.29\components\lib\net_rim_api.jar" C:\net_rim_bb_qm_platform.jar


Error preverifying class net.rim.blackberry.api.bbm.platform.ui.chat.component.SmileyScreen

 

java/lang/NoClassDefFoundError: net/rim/device/api/ui/component/TextInputDialog

 

 

Does anyone know what this means and have a resolution?


Thanks!

Harry

 

Developer
Posts: 653
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

Just not sure why you are preverifying the file. I didn't have to do that...I'm running in Eclipse.

Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Developer
Posts: 300
Registered: ‎03-12-2009
My Device: Not Specified

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

Because when i try to sign the file to go on a real device, it asks me for a signing key that I don't have

Developer
Posts: 79
Registered: ‎09-22-2010
My Device: 9700

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

i also facing Same Problems in Netbeans.

can Any one plz help to resolve this

ErrorMsg :

Error preverifying class net.rim.blackberry.api.bbm.platform.ui.chat.component.SmileyScreen
    java/lang/NoClassDefFoundError: net/rim/device/api/ui/component/TextInputDialog.

 

it seems that ib BBM sdk  jar TextinputDialog class is not present.

Developer
Posts: 653
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

You will need signing keys to be able to run the app on the device.  I recommend registering with RIM to get the keys.


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Developer
Posts: 79
Registered: ‎09-22-2010
My Device: 9700

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

 


JaredCo wrote:

You will need signing keys to be able to run the app on the device.  I recommend registering with RIM to get the keys.



hi

thanks for reply,

but this error is in build process, in netbeans i not able to build my Application, i just extracted jar and checked , class TextinputDialog is not inside BBM plateform jar, so in preverify i get NO Class Found Error:

once Build process is Done i will Add Signing in App. to Run on Device.

is any solution in this way....

plz reply

 

 

Developer
Posts: 653
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

Sorry about that ... I was answering Footose's question regarding signing of app which is required.

 

No familiar with Netbeans but in Eclipse there was no need to preverify the jar.   Are you using the latest version of BBM SDK - Beta 4 Refresh?


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Developer
Posts: 300
Registered: ‎03-12-2009
My Device: Not Specified

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

 

I have had RIM signing keys for several years.

 

This is asking for an ew signing key which I don't have.

 

I assume it has something to do with this thread:

 

http://supportforums.blackberry.com/t5/Java-Development/Install-BBM-6-on-actual-device-to-test-BBM-S...

 

Developer
Posts: 300
Registered: ‎03-12-2009
My Device: Not Specified

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

And also - I'm using eclipse as well... same issue.

Developer
Posts: 653
Registered: ‎02-03-2010
My Device: Z10 LE
My Carrier: Rogers

Re: Preverfiy net_rim_bb_qm_platform.jar BBM 6 SDK error

I have apps using BBM platform signed and running on my Torch using normal signing keys.  Three things to look out for :

 

1) Make sure you are using the new BBM SDK refresh build

 

2) Don't tick the bbm sdk lib to be included in the Order&Export tab in Eclipse.

 

3) Make sure you have BBM 6.0 installed on your device which you get from the Beta Zone.


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing