Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
rezkev
Posts: 31
Registered: ‎02-03-2010
My Device: 8520

Re: Problem packaging with the 1.5 Eclipse plug-in

[ Edited ]

When I delete it, the error still remains the same.

I'm excluding the folder containing this and one another file in the build path.

Here is the project tree:

projectTree.jpg

 

 

And here the exclusion of the path:

 buildPathExclusion.jpg

 

Thanks a lot

Eva Rezkova

Please use plain text.
Developer
simon_hain
Posts: 16,001
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: Problem packaging with the 1.5 Eclipse plug-in

After booting my PC anew today i had to open the app_descriptor again to be able to build the project.
so it seems that, whatever value is set when i open the app descriptor, is only saved in RAM.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
rezkev
Posts: 31
Registered: ‎02-03-2010
My Device: 8520

Re: Problem packaging with the 1.5 Eclipse plug-in

I noticed the same and even yesterday after some tries without closing Eclipse, after some while I had to open the app_descriptor to be able to compile (or try to compile).

Simon do you have any idea where could be the another problem? It must be somewhere noticed to compile this file event if it's not on build path.

Please use plain text.
Administrator
MSohm
Posts: 14,410
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Problem packaging with the 1.5 Eclipse plug-in

Could one of you submit a project that exibts this error to Issue Tracker or devsupport@rim.com so we can reproduce it here?  Thanks!

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Developer
rezkev
Posts: 31
Registered: ‎02-03-2010
My Device: 8520

Re: Problem packaging with the 1.5 Eclipse plug-in

I found a solution but still don't know the reason for this behavior. Finally I had to delete the project from the workspace, delete all project files on the disk and then recreate the project new with the copy of sources. Deleting only project in workspace was not enough.

BTW I can confirm the behavior Simon described, each time I close Eclipse, I have to open the app_descriptor to be able to package the problem projects.

Please use plain text.
Trusted Contributor
sakfg
Posts: 224
Registered: ‎08-09-2011
My Device: 9550
My Carrier: BBprogrammer

Re: Problem packaging with the 1.5 Eclipse plug-in

[ Edited ]

After changing my Blackberry java sdk to 1-5 

 

While packaging the app throught the simulator i got the following Exception..

 

 

Description Resource Path Location Type
C:\name\Project\file\deploy.jar can not be exported because some class in it was eviscerated (content of a class file was removed). project line 0 BlackBerry Packaging Problem

Please use plain text.
Trusted Contributor
sakfg
Posts: 224
Registered: ‎08-09-2011
My Device: 9550
My Carrier: BBprogrammer

Re: Problem packaging with the 1.5 Eclipse plug-in

[ Edited ]

Members can any one help me!!

 

Description Resource Path Location Type
C:\name\projct\lib\rt.jar can not be exported because some class in it was eviscerated (content of a class file was removed). projectname line 0 BlackBerry Packaging Problem

 

i got this Error ,is there any solution for this..

Please use plain text.
Developer
simon_hain
Posts: 16,001
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: Problem packaging with the 1.5 Eclipse plug-in

this does not seem to be related, better use your own thread for it.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
New Developer
mruthven
Posts: 20
Registered: ‎07-21-2008
My Device: Not Specified

Re: Problem packaging with the 1.5 Eclipse plug-in

MSohm, did you ever get a sample project that was encountering this error?  I have one if you still need that.

Please use plain text.
Administrator
MSohm
Posts: 14,410
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Problem packaging with the 1.5 Eclipse plug-in

No, please add one to Issue Tracker if you can.  Thanks!

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.